Cant Update Pacakge List (Dumb AP)

Just setup my router as a dump ap and I wanted to install a couple of things to make configurations for the router but I can't update the package list. I've pinged and everything works fine, I have an internet connection and everything not really sure why I cant update packages.

Have you done ping tests from client devices or from the dumb ap itself (via an ssh session)?

1 Like

I did it from cmd on my laptop and diagnostics from the openwrt gui.

you gave it a static ip and did not set a dns server

Yes I gave it a static IP and set the dns server to my main routers gateway(192.168.0.1).

Probably best to see your config. Also post the errors you get when you try to update the package lists.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

L

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'nothing here'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.0.1'
        list dns '192.168.0.1'
        option ipaddr '192.168.0.2'

config device 'lan_eth0_1_dev'
        option name 'eth0.1'
        option macaddr 'nothing here'

config device 'wan_eth0_2_dev'
        option name 'eth0.2'
        option macaddr 'nothing here'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'
config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:01.0/0000:02:00.0'
        option htmode 'HT20'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option key 'nothinghere'
        option ssid 'Chimmy'
        option encryption 'psk2'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key 'nothing'
        option ssid 'Chimmy-5G'
        option encryption 'psk2'
config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'
cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

and what are the errors when you run the following:
opkg update

also, what OpenWrt release are you currently using?

Iā€™m on 19.07.3


Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Collected errors:
 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.3/targets/ramips/mt7621/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.3/targets/ramips/mt7621/kmods/4.14.180-1-2e88863ccdd594fb8e842df3c25842ee/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.3/packages/mipsel_24kc/base/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.3/packages/mipsel_24kc/luci/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.3/packages/mipsel_24kc/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.3/packages/mipsel_24kc/routing/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.3/packages/mipsel_24kc/telephony/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

The opkg update command failed with code 7.

what are the results of a lookup and ping test (from the dumb AP itself via ssh):

nslookup downloads.openwrt.org
ping downloads.openwrt.org

nslookup downloads.openwrt.org
;; connection timed out; no servers could be reached

root@OpenWrt:~# ping downloads.openwrt.org
ping: bad address 'downloads.openwrt.org'

Is 192.168.0.1 your main router's IP address? Can you ping 192.168.0.1?

Yes it us my main router IP.

64 bytes from 192.168.0.1: seq=0 ttl=64 time=4.394 ms
64 bytes from 192.168.0.1: seq=1 ttl=64 time=1.837 ms
64 bytes from 192.168.0.1: seq=2 ttl=64 time=1.821 ms
64 bytes from 192.168.0.1: seq=3 ttl=64 time=3.394 ms
64 bytes from 192.168.0.1: seq=4 ttl=64 time=1.692 ms
64 bytes from 192.168.0.1: seq=5 ttl=64 time=2.384 ms
64 bytes from 192.168.0.1: seq=6 ttl=64 time=4.115 ms
64 bytes from 192.168.0.1: seq=7 ttl=64 time=1.793 ms
64 bytes from 192.168.0.1: seq=8 ttl=64 time=1.835 ms
64 bytes from 192.168.0.1: seq=9 ttl=64 time=2.488 ms
64 bytes from 192.168.0.1: seq=10 ttl=64 time=1.878 ms
64 bytes from 192.168.0.1: seq=11 ttl=64 time=2.321 ms
64 bytes from 192.168.0.1: seq=12 ttl=64 time=1.871 ms
64 bytes from 192.168.0.1: seq=13 ttl=64 time=2.365 ms
64 bytes from 192.168.0.1: seq=14 ttl=64 time=1.758 ms
64 bytes from 192.168.0.1: seq=15 ttl=64 time=2.067 ms
64 bytes from 192.168.0.1: seq=16 ttl=64 time=1.850 ms
64 bytes from 192.168.0.1: seq=17 ttl=64 time=2.461 ms
64 bytes from 192.168.0.1: seq=18 ttl=64 time=3.237 ms
64 bytes from 192.168.0.1: seq=19 ttl=64 time=6.372 ms
64 bytes from 192.168.0.1: seq=20 ttl=64 time=1.989 ms
64 bytes from 192.168.0.1: seq=21 ttl=64 time=2.074 ms
64 bytes from 192.168.0.1: seq=22 ttl=64 time=1.907 ms
64 bytes from 192.168.0.1: seq=23 ttl=64 time=1.803 ms
64 bytes from 192.168.0.1: seq=24 ttl=64 time=2.110 ms
64 bytes from 192.168.0.1: seq=25 ttl=64 time=2.622 ms
64 bytes from 192.168.0.1: seq=26 ttl=64 time=2.025 ms
64 bytes from 192.168.0.1: seq=28 ttl=64 time=1.962 ms
64 bytes from 192.168.0.1: seq=29 ttl=64 time=1.946 ms
64 bytes from 192.168.0.1: seq=30 ttl=64 time=2.768 ms
64 bytes from 192.168.0.1: seq=31 ttl=64 time=2.047 ms
64 bytes from 192.168.0.1: seq=32 ttl=64 time=2.005 ms
64 bytes from 192.168.0.1: seq=33 ttl=64 time=1.904 ms
64 bytes from 192.168.0.1: seq=34 ttl=64 time=2.639 ms
64 bytes from 192.168.0.1: seq=35 ttl=64 time=3.450 ms
64 bytes from 192.168.0.1: seq=36 ttl=64 time=2.466 ms
64 bytes from 192.168.0.1: seq=37 ttl=64 time=1.984 ms
64 bytes from 192.168.0.1: seq=38 ttl=64 time=1.946 ms
64 bytes from 192.168.0.1: seq=39 ttl=64 time=2.013 ms
64 bytes from 192.168.0.1: seq=40 ttl=64 time=1.997 ms
64 bytes from 192.168.0.1: seq=41 ttl=64 time=2.085 ms
64 bytes from 192.168.0.1: seq=42 ttl=64 time=1.928 ms
64 bytes from 192.168.0.1: seq=43 ttl=64 time=2.119 ms
64 bytes from 192.168.0.1: seq=44 ttl=64 time=2.415 ms
64 bytes from 192.168.0.1: seq=45 ttl=64 time=1.923 ms
64 bytes from 192.168.0.1: seq=46 ttl=64 time=2.272 ms
64 bytes from 192.168.0.1: seq=47 ttl=64 time=2.398 ms
64 bytes from 192.168.0.1: seq=48 ttl=64 time=1.998 ms
64 bytes from 192.168.0.1: seq=49 ttl=64 time=1.994 ms
64 bytes from 192.168.0.1: seq=50 ttl=64 time=2.174 ms
64 bytes from 192.168.0.1: seq=51 ttl=64 time=4.900 ms
64 bytes from 192.168.0.1: seq=52 ttl=64 time=1.895 ms
64 bytes from 192.168.0.1: seq=53 ttl=64 time=1.937 ms
64 bytes from 192.168.0.1: seq=54 ttl=64 time=1.938 ms
64 bytes from 192.168.0.1: seq=55 ttl=64 time=1.854 ms
64 bytes from 192.168.0.1: seq=56 ttl=64 time=2.201 ms
64 bytes from 192.168.0.1: seq=57 ttl=64 time=2.752 ms
64 bytes from 192.168.0.1: seq=58 ttl=64 time=1.963 ms
64 bytes from 192.168.0.1: seq=59 ttl=64 time=2.038 ms
64 bytes from 192.168.0.1: seq=60 ttl=64 time=2.015 ms
64 bytes from 192.168.0.1: seq=61 ttl=64 time=1.928 ms
64 bytes from 192.168.0.1: seq=62 ttl=64 time=2.060 ms
64 bytes from 192.168.0.1: seq=63 ttl=64 time=2.006 ms
64 bytes from 192.168.0.1: seq=64 ttl=64 time=2.000 ms
64 bytes from 192.168.0.1: seq=65 ttl=64 time=2.160 ms
64 bytes from 192.168.0.1: seq=67 ttl=64 time=1.936 ms
64 bytes from 192.168.0.1: seq=68 ttl=64 time=2.124 ms
64 bytes from 192.168.0.1: seq=69 ttl=64 time=2.035 ms
64 bytes from 192.168.0.1: seq=70 ttl=64 time=1.769 ms
64 bytes from 192.168.0.1: seq=71 ttl=64 time=2.013 ms
64 bytes from 192.168.0.1: seq=72 ttl=64 time=1.802 ms
64 bytes from 192.168.0.1: seq=73 ttl=64 time=2.411 ms
64 bytes from 192.168.0.1: seq=74 ttl=64 time=1.830 ms
64 bytes from 192.168.0.1: seq=75 ttl=64 time=2.152 ms
64 bytes from 192.168.0.1: seq=76 ttl=64 time=1.895 ms
64 bytes from 192.168.0.1: seq=77 ttl=64 time=1.879 ms
64 bytes from 192.168.0.1: seq=78 ttl=64 time=1.723 ms
64 bytes from 192.168.0.1: seq=79 ttl=64 time=1.830 ms
64 bytes from 192.168.0.1: seq=80 ttl=64 time=1.781 ms
64 bytes from 192.168.0.1: seq=81 ttl=64 time=1.746 ms
64 bytes from 192.168.0.1: seq=82 ttl=64 time=1.746 ms
64 bytes from 192.168.0.1: seq=83 ttl=64 time=1.838 ms
64 bytes from 192.168.0.1: seq=84 ttl=64 time=1.824 ms
64 bytes from 192.168.0.1: seq=85 ttl=64 time=1.839 ms
64 bytes from 192.168.0.1: seq=86 ttl=64 time=1.958 ms
64 bytes from 192.168.0.1: seq=87 ttl=64 time=2.131 ms
64 bytes from 192.168.0.1: seq=88 ttl=64 time=1.893 ms
64 bytes from 192.168.0.1: seq=89 ttl=64 time=1.954 ms
64 bytes from 192.168.0.1: seq=90 ttl=64 time=2.148 ms
64 bytes from 192.168.0.1: seq=91 ttl=64 time=1.859 ms
64 bytes from 192.168.0.1: seq=92 ttl=64 time=1.942 ms
64 bytes from 192.168.0.1: seq=93 ttl=64 time=1.830 ms
64 bytes from 192.168.0.1: seq=94 ttl=64 time=1.872 ms
64 bytes from 192.168.0.1: seq=95 ttl=64 time=2.626 ms
64 bytes from 192.168.0.1: seq=96 ttl=64 time=2.429 ms
64 bytes from 192.168.0.1: seq=97 ttl=64 time=1.685 ms
64 bytes from 192.168.0.1: seq=98 ttl=64 time=2.096 ms
64 bytes from 192.168.0.1: seq=99 ttl=64 time=2.389 ms
64 bytes from 192.168.0.1: seq=100 ttl=64 time=1.771 ms
64 bytes from 192.168.0.1: seq=101 ttl=64 time=1.887 ms
64 bytes from 192.168.0.1: seq=102 ttl=64 time=1.848 ms
64 bytes from 192.168.0.1: seq=103 ttl=64 time=1.858 ms
64 bytes from 192.168.0.1: seq=104 ttl=64 time=2.497 ms
64 bytes from 192.168.0.1: seq=105 ttl=64 time=1.828 ms
64 bytes from 192.168.0.1: seq=106 ttl=64 time=2.306 ms
64 bytes from 192.168.0.1: seq=107 ttl=64 time=1.853 ms
64 bytes from 192.168.0.1: seq=108 ttl=64 time=1.762 ms
64 bytes from 192.168.0.1: seq=109 ttl=64 time=2.275 ms
64 bytes from 192.168.0.1: seq=110 ttl=64 time=1.827 ms
64 bytes from 192.168.0.1: seq=111 ttl=64 time=1.900 ms
64 bytes from 192.168.0.1: seq=112 ttl=64 time=1.881 ms
64 bytes from 192.168.0.1: seq=113 ttl=64 time=1.867 ms
64 bytes from 192.168.0.1: seq=114 ttl=64 time=1.789 ms
64 bytes from 192.168.0.1: seq=115 ttl=64 time=1.850 ms
64 bytes from 192.168.0.1: seq=116 ttl=64 time=1.926 ms
64 bytes from 192.168.0.1: seq=117 ttl=64 time=1.784 ms
64 bytes from 192.168.0.1: seq=118 ttl=64 time=1.786 ms
64 bytes from 192.168.0.1: seq=119 ttl=64 time=1.846 ms
64 bytes from 192.168.0.1: seq=120 ttl=64 time=2.018 ms
64 bytes from 192.168.0.1: seq=121 ttl=64 time=2.642 ms
64 bytes from 192.168.0.1: seq=122 ttl=64 time=1.980 ms
64 bytes from 192.168.0.1: seq=123 ttl=64 time=1.918 ms
64 bytes from 192.168.0.1: seq=124 ttl=64 time=1.829 ms
64 bytes from 192.168.0.1: seq=125 ttl=64 time=1.958 ms
64 bytes from 192.168.0.1: seq=126 ttl=64 time=1.809 ms
64 bytes from 192.168.0.1: seq=127 ttl=64 time=1.774 ms
64 bytes from 192.168.0.1: seq=128 ttl=64 time=2.190 ms
64 bytes from 192.168.0.1: seq=129 ttl=64 time=2.029 ms
64 bytes from 192.168.0.1: seq=130 ttl=64 time=1.841 ms
64 bytes from 192.168.0.1: seq=131 ttl=64 time=1.857 ms
64 bytes from 192.168.0.1: seq=132 ttl=64 time=2.447 ms
64 bytes from 192.168.0.1: seq=133 ttl=64 time=1.979 ms
64 bytes from 192.168.0.1: seq=134 ttl=64 time=1.992 ms
64 bytes from 192.168.0.1: seq=135 ttl=64 time=1.828 ms
64 bytes from 192.168.0.1: seq=136 ttl=64 time=1.819 ms
64 bytes from 192.168.0.1: seq=137 ttl=64 time=1.904 ms
64 bytes from 192.168.0.1: seq=138 ttl=64 time=1.756 ms

It just keeps pinging.

ping 192.168.0.2

Pinging 192.168.0.2 with 32 bytes of data:
Reply from 192.168.0.2: bytes=32 time=1ms TTL=64
Reply from 192.168.0.2: bytes=32 time=1ms TTL=64
Reply from 192.168.0.2: bytes=32 time=1ms TTL=64
Reply from 192.168.0.2: bytes=32 time=1ms TTL=64

Ping statistics for 192.168.0.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 1ms, Average = 1ms

This is what I get when I just do it on my pc command prompt without ssh

How? What am I doing wrong? I followed the steps shown on the website.

That looks wrong to me. Why would the dumb .2 router claim to have DNS server at .2 ??

2 Likes

Your config looked ok to me, but have you already disabled dnsmasq, the DNS service? The dumb AP should have it disabled.

/etc/init.d/dnsmasq disable
/etc/init.d/dnsmasq stop

Ps. And have you already rebooted the router?

1 Like

Yes i disabled firewall, dnsmasq, odhcpd. And yes I also rebooted the router.