Can't untag VLAN on WAC104 (DSA)

I'm unable to untag traffic from my WAC104. The interface can get a DHCP address on the tagged port so I know that it can at least receive tagged traffic but it can't untag. I'm testing this by plugging it into my laptop and checking if I get a DHCP address (which I don't).

Any ideas?

I'm doing a bunch of stuff on this device so sorry if it's confusing. In this case I am trying to untag VLAN5 on lan4

Also, I'm sure it's the only untagged VLAN on that port:
image


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config bridge-vlan
	option device 'br-lan'
	option vlan '2'
	list ports 'lan1:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '3'
	list ports 'lan1:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '4'
	list ports 'lan1:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '6'
	list ports 'lan1:t'

config interface 'Management'
	option proto 'dhcp'
	option device 'br-lan.6'

config device
	option type 'bridge'
	option name 'br-vlan2'
	list ports 'br-lan.2'

config device
	option type 'bridge'
	option name 'br-vlan3'
	list ports 'br-lan.3'

config device
	option type 'bridge'
	option name 'br-vlan4'
	list ports 'br-lan.4'

config interface 'Home'
	option device 'br-vlan2'
	option proto 'none'

config interface 'IoT'
	option device 'br-vlan3'
	option proto 'none'

config interface 'Guest'
	option device 'br-vlan4'
	option proto 'none'

config bridge-vlan
	option device 'br-lan'
	option vlan '5'
	list ports 'lan1:t'
	list ports 'lan4'

config bridge-vlan
	option device 'br-vlan2'
	option vlan '1'
	option local '0'

config bridge-vlan
	option device 'br-vlan3'
	option vlan '1'
	option local '0'

config bridge-vlan
	option device 'br-vlan4'
	option vlan '1'
	option local '0'

config device
	option type 'bridge'
	option name 'br-vlan5'
	list ports 'br-lan.5'

config interface 'test'
	option proto 'dhcp'
	option device 'br-vlan5'


Why don't you try to make the configuration less complicated (without all those additional devices) and set the PVID on lan4?

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config bridge-vlan
	option device 'br-lan'
	option vlan '2'
	list ports 'lan1:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '3'
	list ports 'lan1:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '4'
	list ports 'lan1:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '5'
	list ports 'lan1:t'
	list ports 'lan4:u*'

config bridge-vlan
	option device 'br-lan'
	option vlan '6'
	list ports 'lan1:t'

config interface 'Home'
	option device 'br-lan.2'
	option proto 'none'

config interface 'IoT'
	option device 'br-lan.3'
	option proto 'none'

config interface 'Guest'
	option device 'br-lan.4'
	option proto 'none'

config interface 'test'
	option proto 'dhcp'
	option device 'br-lan.5'

config interface 'Management'
	option proto 'dhcp'
	option device 'br-lan.6'
1 Like

That worked perfectly, thanks!

I guess all of the bridges I made before interfered with the br-lan so maybe that's why it wasn't working.

Previously I was having issues not being able to connect my wireless networks to interfaces when they weren't connected to a bridge so I had to create bridges for them. I guess because this is a VLAN on the bridge it works?

Also, it looks like it still works if I don't set the PVID. What does this do when there is only one untagged VLAN on a port?

That's correct.

In any case you cannot configure more than one untagged VLAN on a port. The PVID is the VLAN id that should be assigned to the untagged frames entering the switch on that port. That VLAN id must be stripped from the frames, leaving the port.

90:9a:4a:96:c5:8a > 8c:de:f9:a4:1e:54, 802.1Q, length 102: vlan 10, p 0, ethertype IPv4, 192.168.92.15 > 192.168.92.139: ICMP echo request, id 18939, seq 0, length 64
8c:de:f9:a4:1e:54 > 90:9a:4a:96:c5:8a, IPv4, length 98: 192.168.92.139 > 192.168.92.15: ICMP echo reply, id 18939, seq 0, length 64

Most of the switches will automatically assign the correct VLAN id if the port is configured as an untagged member of a specific VLAN. That's why it works for you both ways.

However, I had a case where the input frames were incorrectly marked with the default VLAN id (1) if the PVID was not set. So better set it up, it costs you nothing.

1 Like

Gotcha, ok :slight_smile:

I have a better understanding of how DSA drivers work now.

Thanks again!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.