Cant start Luci (after opkg upgrade packages)

I am using the latest version of openwrt , i ran a sysupgrade keeping the settings everything was working fine until i looked that some luci packages had upgrades available after applying those and restart the router i got the following:

/usr/lib/lua/luci/model/cbi/rtorrent/download.lua:7: module 'luci.controller.admin.system' not found:
	no field package.preload['luci.controller.admin.system']
	no file './luci/controller/admin/system.lua'
	no file '/usr/share/lua/luci/controller/admin/system.lua'
	no file '/usr/share/lua/luci/controller/admin/system/init.lua'
	no file '/usr/lib/lua/luci/controller/admin/system.lua'
	no file '/usr/lib/lua/luci/controller/admin/system/init.lua'
	no file './luci/controller/admin/'
	no file '/usr/lib/lua/luci/controller/admin/'
	no file '/usr/lib/lua/'
	no file './'
	no file '/usr/lib/lua/'
	no file '/usr/lib/lua/'
stack traceback:
	[C]: in function 'require'
	/usr/lib/lua/luci/model/cbi/rtorrent/download.lua:7: in main chunk
	[C]: in function 'require'
	/usr/lib/lua/luci/controller/rtorrent.lua:5: in main chunk
	[C]: in function 'require'
	/usr/lib/lua/luci/dispatcher.lua:1081: in function 'createindex'
	/usr/lib/lua/luci/dispatcher.lua:1192: in function 'createtree'
	/usr/lib/lua/luci/dispatcher.lua:694: in function 'menu_json'
	/usr/lib/lua/luci/dispatcher.lua:795: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:478: in function </usr/lib/lua/luci/dispatcher.lua:477>

i tried to isntall rtorrent but the issue persisted.
any help is welcome.

i commented that line and now i can load it but i would like to understand what is going on.


You have somehow incoherent set of packages. Almost looks like the main LuCI modules are missing.

Mass-upgrading packages can lead to problems.

Easiest solution might be to use firstboot command to reset router, and to start from scratch.

In the long run, it is easiest to flash the router and install all needed packages at the same time, so that you have a coherent set (of the system and GUI packages). Preferred solution is to compile a personal firmware.


Upgrading packages (via the CLI opkg upgrade command or the LuCI Upgrade... button) can result in major problems. It is generally highly discouraged, unless you know what you are doing or if there is specific instruction to do so.


hi, thanks for the advices.

I am working with extroot and i didnt format the partition because i dont want to loose all the work done there.

but i guess there is no way around it, ill have to start from scratch.

Take a backup before you do anything else!