Can't SSH into 18.06.5 on ZBT WE3526

Hello everyone! It's my first day on the Openwrt Forum!

I have a ZBT WE3526, and per the beginner installation documentation I tried flashing the latest image on that page, and starting my router.

  • Going to doesn't show LUCI.
  • SSH-ing also doesn't work.

Here's the image I used: I can't put more than 2 links cuz I'm a new user but it's basically the image on the device page here's a stripped version of the link: /releases/18.06.5/targets/ramips/mt7621/openwrt-18.06.5-ramips-mt7621-zbtlink_zbt-we3526-squashfs-sysupgrade.bin

I'm assuming it's because I'm using the upgrade image as opposed to an installation image? but there were no installation image links on the router page :frowning: what can I do?

try to re-flash from uboot

And try the 19.07 image while you're at it.

What's uboot? How can I do that? is it okay that I have a sysupgrade.bin file? can sysupgrade.bin files also used for factory flashing?

Your link is for we1326, my device is a we3526, wouldn't that be a problem? I'll try 19.07 for both.

Apologies, fixed the link. Uboot is your bootloader. Check your manual to see if there's a recovery mode, with a bit of luck it has one (but usually one uses a factory image with it, and there is none for your device).

Yeah, I found a document for getting into recovery mode for an older ZBT router, thankfully mine had the same procedure. I've been using the sysupgrade files with that... I'm also trying to build from source using this link but that's taking a while. I hope it generates a factory image?

Tried the 19.07 image, same results. Can't SSH into it. Is there a way I can make a factory image?

I'm afraid not, since what the buildbots build is usually what you'll get building yourself (except for the initramfs images maybe).

My advice would be to restore the OEM firmware; the fact OpenWrt only offers a sysupgrade binary usually implies you can either get a shell on the OEM firmware and call the 'sysupgrade' command from there, or just upload the OpenWrt sysupgrade binary through the web interface.


I have a stable image from the previous intern that was working here... I'll try sysupgrade from that version... hopefully it'll work.

No need to use factory image for this router. Use 19.07.7 (or whatever else is the latest stable by the time you'll read it) and flash it from recovery mode.

Quick reminder how to summon recovery mode:

  1. disconnect power from router
  2. press "RESET" button on the back
  3. apply power to the router and release the button after around 3 seconds
  4. set your PC to static IP
  5. go to and flash firmware using big button with Chinese description on it (use Google Lens to translate if you really wanna).