Can't set static IP to 192.168.0.111

Hi guys,
I'm pre-configuring a dump AP at my home to be installed somewhere else. A few years ago I installed this router there because the people were complaining about WiFi speeds and stability. I had just started looking at OpenWrt and just hooked this one up and the complaining stopped :slight_smile: Some time passed, I fiddle around with OpenWrt more and realise there are some benefits to be had from more specific setups such as configuring it as a dump AP (I never could access the AP when I was around there without disconnecting it from the main router, now I know why).
And so, I took this router with me last week so I could update it to the latest OpenWrt version and thought to myself, let's make it a proper dumb AP.
The instructions for dumb AP are clear enough, no issue there. However, when I try to set the static IP to 192.168.0.111 (the main router issues IPs in the 192.168.0.x range, and I have set the DHCP on it to give 192.168.0.111 to this particular dumb AP), it just doesn't work. The timer counts from 90 to 0, and no matter what browser I use or how many times I try, it won't take. By the way, I also tried 192.168.0.99, still no dice. What am I doing wrong? Some details:

  • Archer C58
  • OpenWrt v22.03.5
  • clean install

For the record, I have been able to give it the static IP of 192.168.1.111, just not the 192.168.0.111

Curious to hear what might be the issue!

If

then there is no need to

It should be DHCP then.

If you want static assignment instead of DHCP then you should use "Apply unchecked" in the GUI.

That's true in normal cases and would be the endstate, however I want to prepare the AP before I head over there and hook it up. Thus, I'm looking for a static IP set up. Also, it has now come to solving this mystery anyway, using DHCP or not :wink:

If you try to set it via LuCI and set it to an IP that also changes subnet from 192.168.1.x to 192.168.0.x, you also need to change the PC's own IP to match the new subnet.

There is a softbrick prevention logic in LuCI, where your pc browser needs to reconnect in a minute, otherwise the setting change is rolled back. Make sure that your pc renews it's DHCP address quickly after you change the router.

Easier would be to edit the network config file in /etc/config directly, and reboot.

3 Likes

@hnyman this sounds logical, will give it a go later today. Thanks for your reply, I'll post results here :slight_smile:

This was the solution. As simple as disconnecting and reconnecting the ethernet cable. Thanks a bunch!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.