Can't seem to router IPv4

Hi Guys. I have an Asus Rt-AC51U flashed to OpenWRT 20.03.5 and its being weird!

I tried to set it up as a VPN router but although the Wireguard intersect to the VPN provider was connected and packet counts are increasing it didn't seem to be working. I had followed all the guides to the letter - but it didnt work!

So I did a reset, took it back to default, I think and tried it as a normal router. Did nothing to it and tried to surf the net .. works but if I go to I-address.com it show me as being at an unknown country, unknown ISP. Also if I disable the WAN6 interface everything stops! It seems to be routing everything through v6

How do I make it work as a normal router. I just want a 'normal' routing on it and for v4 to work as you would expect!

I'm not experienced with OpenWRT and stuck. Can someone tell me what to do to get out of this.

Thanks in advance

Dave

FYI, that site is doesn't show IP.

I would suggest disabling IPv6 on thr client to test, not the router. There's a few reasons why it woulda stopped doing that.

Next, are you asking about Wireguard?

If so, seeing that config would be helpful to assist you.

Sorry, the spell checker took over, it should have read ipaddress.com

Don't worry about wireguard, thats not important. I just want to be able to route IPv4 correctly

When you say disable IPv6 on the client .... what do you mean? Which client?

Sorry to seem so clueless

let's see your configuration:

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Thank you

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd9f:37b5:df93::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config device
	option name 'eth0.1'
	option macaddr 'a8:5e:45:f4:c6:34'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.4.1'

config interface 'wan'
	option device 'eth0.2'
	option proto 'dhcp'
	option delegate '0'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0 6t'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/10180000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option disabled '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

root@OpenWrt:~# cat /etc/config/firewall
config defaults
	option syn_flood	1
	option input		ACCEPT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	00:11:22:33:44:66
#	option target	REJECT

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		192.168.16.235
#	option dest_port	80
#	option proto		tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#	option src		wan
#	option src_dport	22001
#	option dest		lan
#	option dest_port	22
#	option proto		tcp

### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port	80
#	option dest		wan
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT

#config redirect
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
root@OpenWrt:~# 

shot in the dark here but you could try modifying "option input REJECT" to ACCEPT, then a reboot.

No. Please do not do this. That will expose your router's local services (i.e. ssh and luci web interface) to the internet. This should never be set to accept unless the upstream network is fully trusted (i.e. a trusted LAN).

2 Likes

Quite Right! sorry for the oversight! I simply meant for testing different configurations and diagnosing his issue, in a secure environment of course! But either way your right its definitely not best practice at all.

Do my network configurations seem 'normal'? I expected that when I setup the router, installed openers, its basic behaviour would be to route my LAN activity to the net and I could just surf normally. Currently the wireless is disabled, I'm connected with ethernet.

Yes, the config is pretty close to defaults and should generally work.

What do you see in the ipv4 upstream section of the main status page? Just show the first two octets on bold: aaa.bbb.ccc.ddd

At least in my case it shows a wrong IPv4 address.
Instead of 79.201.x.x it shows a 244.247.x.x address.

1 Like

I hope this helps

Protocol: DHCP client
Address: 192.168.x.x/24
Gateway: 192.168.x.x
DNS 1: 192.168.x.x
Expires: 11h 17m 45s
Connected: 12h 42m 15s

Device: Software VLAN: "eth0.2"
MAC address:

Are you running your openwrt router behind another router, such as one provided by your isp. You have an rfc1918 address on the openwrt wan.

What is the 3rd octet? Is it 192.168.4.x?

Hi again, sorry, just back from work ....

Yes, exactly that, its running behind my ISP router which is giving out a 192.168.1.x address via dhcp

So this seems unlikely to conflict.

Login to the OpenWrt router and run the following ping tests:

Report what happens for each.

Using the diagnostics on the router I did the IPv4 Ping. all succeeded, no lost packets just speed was different as you would expect. the fist was quickest 3ms, then the google dns about 18ms, then the google.com at 19ms, roughly.

ok... now from a computer connected by ethernet to the OpenWrt router, run the same ping tests (and add 192.168.4.1 to the mix, too).

Pretty much the same again. 192.168.4.1 in 0.8ms, the next in 4.1ms, google dns in 19ms, google.com in 20ms

so it seems everything is working as expected based on these diagnostics.

What does nslookup google.com produce (from the router, but also from your computer)?

1 Like