Cant see interface. New install. Archer C20 v4

Hi all. I have a TP Link Archer C20 v 4 and followed the instructions on the site. Router boots up and gives me wifi OpenWrt and when i connect it reads as OpenWrt. If I go to nothing shows up and connection failed.

If I connect it thru another router (funbox) then connection reads as the funbox and internet works fine.

I saw other posts saying to boot into safe mode which I did and light keeps blinking fast and thats it. Nothing I do gets me to the OpenWrt router login screen.

Tried static IP on client device? Unplugging wan cable and using lan connection might help as well, afaik wrt has wifi disabled by default.

Tried that already. Nothing. Wifi was up and working in open state. No password needed and labeled as OpenWrt

If you installed a snapshot Luci isn't installed, just run -

opkg update

opkg install luci

And @mic_glow is right, wifi is usually disabled by default, so that's kind of odd.

Ill try that thanks. Heres what I used.

So when i ssh into the router it says snapshot.

However the commands dont work. Unable to connect error. So i downloaded everything and transfered the files over to root.

Run opkg install and get this error: packages for luci-proto-core found, but incompatible with the architectures configured. Cannot install package luci-proto-core

Hmm, curious where you got luci-proto-core, I can't seem to find it anywhere and it doesn't seem to be installed on my system either. If you want to make things a bit easier you can just install the stable build 18.06.1, it has Luci already installed.

When i looked for how to install luci on openwrt it shows an install page and then provides a link if it needs to be done manually. So i went thru the manual and that was listed.

Im using the latest download from the device page and it didnt work. Would any other build work or a stable build that has luci on it already? This is really getting frustrating and even my asus theres no recovery tool or firmware download on asus site any longer. Thanks for your help.

Here's the 18.06.1 downloads for your build, it has Luci installed by default, since you're already on OpenWrt you'll need the squashfs-sysupgrade.bin. Transfer the sysupgrade file to /tmp, ssh in, cd to /tmp and run sysupgrade -n your/file/name/here. That should get you up and running with the gui (Luci) available at

edit - it looks like you only have 8mb flash, so you won't be able to fit much else with Luci installed.

1 Like

Thanks. All i needed was to be able to run wireguard for netflix lol. Thats what this whole thing is about. Using ipv4 on my vpn keeps getting blocked. Using ipv6 on wiregaurd works great.

Thank you so much. That worked and got it interface now!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.