Can't save any changes on EA7500V2

Hello all,

I took the plunge into installing OpenWRT on my Linksys EA7500V2, and at first everything seems like it was working great, until I reboot the device. Whether I unplug or do a reboot via the LuciGui, everything changes back to default and none of my changes gets committed.

I am on 21.02.1 and i used the Sysupgrade method with the following rom:

I am very new to CLI and I did some googling around and I did a Free also a df -hT and these are the outputs:

root@OpenWrt:~# free
              total        used        free      shared  buff/cache   available
Mem:         252048       31820      202484        1180       17744      186192
Swap:             0           0           0
root@OpenWrt:~# df -hT
Filesystem           Type            Size      Used Available Use% Mounted on
/dev/root            squashfs        3.8M      3.8M         0 100% /rom
tmpfs                tmpfs         123.1M      1.1M    122.0M   1% /tmp
tmpfs                tmpfs         123.1M     76.0K    123.0M   0% /tmp/root
overlayfs:/tmp/root  overlay       123.1M     76.0K    123.0M   0% /
tmpfs                tmpfs         512.0K         0    512.0K   0% /dev

Any help is greatly appreciated!

Same issue in another topic: Opkg update failed with code 7 on Linksys EA7500v2 - #7 by samsonluk
What errors are in the system log and kernel log about overlay, jffs2 and ubi?

I just checked the Kernel and System log via the GUI and searched for "error" and this was the only return:

Sun Oct 24 09:01:40 2021 kernel: [   10.435061] IPv6: ADDRCONF(NETDEV_CHANGE): lan1: link becomes ready
Sun Oct 24 09:01:40 2021 kern.notice kernel: [   10.531553] UBIFS (ubi0:1): Mounting in unauthenticated mode
Sun Oct 24 09:01:40 2021 kern.err kernel: [   10.537229] UBIFS error (ubi0:1 pid 655): 0x802371dc: 'compressor "zstd" is not compiled in
Sun Oct 24 09:01:40 2021 user.err kernel: [   10.546586] mount_root: failed to mount -t ubifs /dev/ubi0_1 /tmp/overlay: No error information
Sun Oct 24 09:01:40 2021 kernel: [   10.555592] mount_root: overlay filesystem has not been fully initialized yet
Sun Oct 24 09:01:40 2021 kernel: [   10.563109] mount_root: switching to ubifs overlay
Sun Oct 24 09:01:40 2021 user.err kernel: [   10.567996] mount_root: switching to ubifs failed - fallback to ramoverlay
Sun Oct 24 09:01:40 2021 user.warn kernel: [   10.578677] urandom-seed: Seed file not found (/etc/urandom.seed)
Sun Oct 24 09:01:40 2021 kernel: [   10.659692] mt7530 mdio-bus:1f lan1: Link is Down

This is a dual boot device. Did you flash twice with sysupgrade? Try installing luci-app-advanced-reboot to check which partition you are booting from and that both partitions are running 21.02.1.

Hi Spong, no I only flashed once, do I just put this command on the ssh terminal?

No, you would do this via web admin. If you are only using terminal then what does command fw_printenv boot_part give you? You can do opkg update && opkg install luci-app-advanced-reboot to install but you need to go to to see

From your log, you are mounting overlayfs to /tmp/root. This will mean all changes are lost after reboot. Your overlayfs should be mounting to something like /dev/ubi0_1 which indicates to me you are booting from a squashfs-factory image. Install the squashfs-sysupgrade firmware a couple of times to ensure you are not booting a squashfs-factory image.
Do this TWICE.

cd /tmp
sysupgrade /tmp/openwrt-21.02.1-ramips-mt7621-linksys_ea7500-v2-squashfs-sysupgrade.bin

Ok let me try this.

Ok i think im good now, thanks Spongbob, i reflashed it with that command and now the changes seems to be committed. I haven't unplugged the router, but I did reboot from the GUI and that seems to save my changes when it came back.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.