Can't route internet from from a fiber modem

My ISP uses a Huwaei HS8546M5 fiber modem, they come with DHCP and WiFi of course, and I had DCHP turned off in my openwrt TPLINK 1043ND v3.

So I asked them to disable the DHCP server and WiFi in the Huwaei so that I could setup it up in my own router, since I don't have the login to the Huwaei they did it remotely for me while I was on the chat support.

What happened was that I was not able to get internet "flowing" from the Huwaei to my openwrt, the chat support said they could see my router "hooked up" no problem, the Huwaei is located at and the support guy assigned a static lease to my openwrt 1043 by the MAC address that I handed out to him.

I tried setting up my local interface as DHCP, since there was a static ip lease assigned to it and also tried DHCP, no matter what my computer wouldn't get access to the internet.

The cable was on LAN1 in the Huawei and LAN1 in my 1043 router.

Any advise?

Well your Huawei (LAN1 on Huawei) must go in the WAN (blue port) of your 1043 openwrt router if you want to use it for internet access.

Hmmm, I actually did try that for a brief moment after not being able to get it to work and unfortunately that didn't work too, not sure if there was any setting involved, although the tech on the chat kept saying it should be on LAN1 and not WAN in my router.

Will give it another shot!

Yes you have to make OpenWrt route now, since that function is no longer done in the ISP supplied box. A default configuration should work. The WAN is a DHCP client, and the LAN is a DHCP server for your LAN devices. I recommend resetting the router to defaults to start with this new network configuration.

The ISP issues a single IP address by DHCP, which should be directly on the Internet. This IP will be held by your router on the WAN port and network.