Cant revert to stock nor flash gargoyle

Hi.
I have flashed my WR1043ND ver. 1.8 with OpenWrt 22.03.5 r20134-5f15225c1e / LuCI openwrt-22.03 branch git-23.093.57104-ce20b4a. Now i want to flash gargoyle gargoyle_1.14.0-ath79-generic-tplink_tl-wr1043nd-v1-squashfs-sysupgrade.bin.

  1. I tried from UI with no luck. The process goes through:
  • uploading,
  • verifying
  • Flash image?
    The flash image was uploaded. Below is the checksum and file size listed, compare them with the original file to ensure data integrity.
    Click 'Continue' below to start the flash procedure.
  • I uncheck Keep settings then continue
  • Flashing...
  • device restarts and I am still on openWrt.
  1. Then from cli: sysupgrade -n gargoyle_1.14.0-tplink_tl-wr1043nd-v1-sysupgrad
    e.bin. No output and device auto restarts, but i am still on openwrt
  2. So i tried to go back to stock to flash the factory gargoyle from stock
  3. So i got stock firmware from the tplink page, stripped it and tried from UI and cli with -F flag for force, as it was complaining about info missing. The result is the same still on openwrt.

Any help would be appreciated.
Best regards, Bartek

It's been a while since I last powered mine on, but this device is really short on RAM (8/32). In the past I had to actively clear up RAM to succeed flashing. rm /etc/modules.d/* && reboot, connect via ssh, stop dnsmasq, uhttpd, hostapd, run sysupgrade. Sadly this device is way past being viable, which is a pity.

If your installed OEM bootloader has been updated to a later version with push-button tftp recovery support, that would be a viable option as well.

Your solution worked, sort of :).
sysupgrade -n /tmp/gargoyle_1.14.0-tplink_tl-wr1043nd-v1-sysupgr
ade.bin
Thu Apr 27 20:37:35 UTC 2023 upgrade: Commencing upgrade. Closing all shell sessions.
So i guess upgrade did went through.
Unfortunately device refused to work afterwards.
It looks like bootloop. Sys is blinking, lan 4 (connected pc) is lit up. Pc does not get the ip, and after some time device reboots (all diodes light up).

You can try to flash 1.15 instead. 1.14 had several reports of not working on that device, likely due to lack of flash/RAM.

If it also doesn’t work, your only option is to go backwards to 1.12 or 1.13, neither of which are recommended.
Or flash vanilla OpenWrt
Or get a newer device

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.