Can't Revert to Stock Firmware on Asus ACRH-13

I followed the steps here:

ssh root@
ubirmvol /dev/ubi0 -N linux2
sysupgrade -F /bin/busybox

however, I am unable to enter rescue mode. The router reboots, and starts up as normal. I can repeat the steps as many times as I want. It just reboots and everything is back to normal.
It seems like sysupgrade -F with a dummy firmware does not work to "break" the router and go into rescue mode. I thought sysupgrade -F with the wrong file should brick it, or have a long lasting effect, however it doesn't.

Any ideas what else I can try?


I tried running
to reset everything,
and I also tried running the remove ubi0, then sysupgrade -F /bin/busybox
then when it rebooted I manually held the reset button, the blue light started flashing,
but the rescue utility is stuck on "Search for an available IP"
the router responds to ping in rescue mode, but for some reason the utility is unable to connect to it.
Any ideas what I can do to get rescue mode working? I believe rescue mode enables rescue only if it finds a problem.. deleting ubi0 should've helped with that, but for some reason it's not working.

I managed to revert it..
had to do:
ubirmvol /dev/ubi0 -N linux2
ubirmvol /dev/ubi0 -N linux

then the router reboots in rescue, and will never boot again normally.. always flashing blue rescue mode.
The asus restoration tool did not work for some reason..

I used a TFTP client,

enter tried upload, it failed..
then click "Download" and enter anything for file name.. for some reason that seems to wake up the server..
then click Upload again, and select the stock TRX file. It uploads, and then reboots on it's own.. takes about 5 minutes to finish, and stock firmware boots up.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.