Can't open or on Mi 3C

I installed OpenWrt 22.03.1 on My Mi 3C router, and now isn't opening. I used the snapshot available on under "Firmware OpenWrt snapshot Upgrade" and followed what was done in this video guide

Now when I try to go to, it says the website doesn't exist. I've tried to open the website in Safari, Chrome and Firefox, both in the regular browser and in incognito, and also tried opening it in Firefox in Windows 10 VM.

Also tried following what's mentioned under 'unbrick' but doesn't open either.

I can ping and also browse the internet while the router is connected. It's essentially acting like a wired repeater right now. How do I fix this?

1 Like

So I ended up installing a snapshot instead of a proper stable build? Silly me! Thanks for the link. I followed the guide and installed Luci, and logged into

I am new to OpenWrt (this is the first time I am playing around with it). Could you also tell me how I can move to a stable build from snapshots?

Upgrade using sysupgrade image from

1 Like