I recently switch to OpenWRT and most of my network is setup and runs well. I have only one problem with IPv6 addresses. Generally, my OpenWRT router (RT 3200, OpenWRT 22.03) is connected to a Draytek Vigor 167 VDSL modem via the WAN port. I establish a PPoE connection to my ISP (Deutsche Telekom VDSL2) via the WAN interface. I also get an IPv4 address assigned and everything works fine. I set the WAN6 interface to DHCPv6 client, the device as alias to wan (@wan). However, WAN6 does not get any IPv6 addresses assigned, the interface overview only says "Protocol: Alias Interface (DHCPv6 client)", without any further details.
Here's the content of me /etc/config/networks
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'xxx::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config interface 'lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option device 'br-lan.1'
option delegate '0'
option ip6assign '64'
option ip6hint '1'
option ip6ifaceid '::1'
config interface 'wan'
option device 'wan'
option proto 'pppoe'
option username 'xxx'
option password 'xxx'
option ipv6 'auto'
config interface 'wan6'
option proto 'dhcpv6'
option reqaddress 'try'
option reqprefix 'auto'
option device '@wan'
config bridge-vlan
option device 'br-lan'
option vlan '1'
list ports 'lan1:t*'
list ports 'lan4:u*'
config bridge-vlan
option device 'br-lan'
option vlan '2'
list ports 'lan1:t'
config bridge-vlan
option device 'br-lan'
option vlan '3'
list ports 'lan1:t'
config bridge-vlan
option device 'br-lan'
option vlan '4'
list ports 'lan1:t'
config bridge-vlan
option device 'br-lan'
option vlan '5'
list ports 'lan1:t'
list ports 'lan2:u*'
list ports 'lan3:u*'
config interface 'dmz'
option proto 'static'
option device 'br-lan.2'
option ipaddr '192.168.20.1'
option netmask '255.255.255.0'
option delegate '0'
option ip6assign '64'
option ip6ifaceid '::1'
config interface 'guest'
option proto 'static'
option device 'br-lan.3'
option ipaddr '192.168.30.1'
option netmask '255.255.255.0'
option delegate '0'
option ip6assign '64'
option ip6ifaceid '::1'
config interface 'phone'
option proto 'static'
option device 'br-lan.4'
option ipaddr '192.168.40.1'
option netmask '255.255.255.0'
option delegate '0'
config interface 'iot'
option proto 'static'
option device 'br-lan.5'
option ipaddr '192.168.50.1'
option netmask '255.255.255.0'
config device
option name 'wan'
config device
option name 'pppoe-wan'
option type 'tunnel'
and /etc/config/dhcp
config dnsmasq
option domainneeded '1'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option localservice '1'
option ednspacket_max '1232'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
list ra_flags 'managed-config'
list ra_flags 'other-config'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config dhcp 'wan6'
option interface 'wan6'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
config dhcp 'dmz'
option interface 'dmz'
option start '100'
option limit '150'
option leasetime '12h'
option ra 'server'
option dhcpv6 'server'
config dhcp 'guest'
option interface 'guest'
option start '100'
option limit '150'
option leasetime '12h'
option ra 'server'
option dhcpv6 'server'
config dhcp 'phone'
option interface 'phone'
option start '100'
option limit '150'
option leasetime '12h'
config dhcp 'iot'
option interface 'iot'
option start '100'
option limit '150'
option leasetime '12h'
and /etc/config/firewall
config defaults
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
option synflood_protect '1'
config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
list network 'lan'
config zone
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
list network 'wan'
list network 'wan6'
config forwarding
option src 'lan'
option dest 'wan'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'
config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'
config zone
option forward 'REJECT'
option input 'REJECT'
option output 'REJECT'
option name 'dmz'
list network 'dmz'
config forwarding
option dest 'wan'
option src 'dmz'
config forwarding
option src 'lan'
option dest 'dmz'
config zone
option output 'ACCEPT'
option input 'REJECT'
option forward 'REJECT'
option name 'guest'
list network 'guest'
config forwarding
option dest 'wan'
option src 'guest'
config zone
option input 'ACCEPT'
option output 'ACCEPT'
option name 'iot'
list network 'iot'
option forward 'REJECT'
config forwarding
option src 'lan'
option dest 'iot'
config zone
option output 'ACCEPT'
option name 'phone'
list network 'phone'
option input 'REJECT'
option forward 'REJECT'
config forwarding
option dest 'wan'
option src 'phone'
config forwarding
option src 'lan'
option dest 'phone'
config rule
option target 'ACCEPT'
option name 'Guest DHCP'
list proto 'udp'
option src_port '68 546'
option dest_port '67 547'
option src 'guest'
config rule
option name 'DMZ DHCP and DNS'
option target 'ACCEPT'
option dest_port '53 67 68 547'
option src 'dmz'
config rule
option name 'Phone DHCP and DNS'
option target 'ACCEPT'
option dest_port '53 67 68 547'
option src 'phone'
config rule
option name 'Allow-Inet-Homematic'
list src_ip '192.168.50.10'
option dest 'wan'
option target 'ACCEPT'
list proto 'tcp'
option dest_port '80 123 443 8443'
option src 'iot'
config rule
option name 'Guest DNS'
option dest_port '53'
option target 'ACCEPT'
list proto 'tcp'
list proto 'udp'
option src 'guest'
config rule
option name 'Allow-Inet-Neato'
list proto 'tcp'
option src 'iot'
list src_ip '192.168.50.118'
option dest 'wan'
option dest_port '443'
option target 'ACCEPT'
Does anyone have an idea what this could be? I previously had a Fritzbox, on which the IPv6 assignment worked, so from the ISP everything should be fine.