Cant obtain ip address

Hello forum,

I have a router in client mode (wlan0) and I cant obtain a ipv4 address from my main router. I dont want to use ipv6. Both routers are Openwrt-18.06. I have a linux laptop and there I can get immediately a ipv4 address. There I can use 'dhclient' to obtain the ip and watch what happens.
logread says:

daemon.notice netifd: wwan (25202): udhcpc: malformed hex string 'root'
daemon.notice netifd: Interface 'wwan' is now down
daemon.notice netifd: Interface 'wwan' is disabled
daemon.notice netifd: Interface 'wwan' is enabled
daemon.notice netifd: Interface 'wwan' is setting up now
  1. Can you give me a hint why I cant get the ip?
  2. Can you give me a cli example how to obtain the ip manually?
    dnsmasq --help
    dnsmasq --no-daemon --interface=wlan0 # does not work

cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc9:fe64:3bae::/48'

config interface 'lan'
        option ifname 'eth1.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option delegate '0'
        option ipaddr '192.168.178.6'
        option broadcast '192.168.178.255'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'static'
        option delegate '0'
        option ipaddr '192.168.77.6'
        option netmask '255.255.255.0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 6t'

config interface 'wwan'
        option proto 'dhcp'
        option delegate '0'
        option clientid 'root'

cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/qca955x_wmac'
        option htmode 'HT20'
        option legacy_rates '1'
        option channel '11'
        option country 'DE'

config wifi-iface
        option network 'wwan'
        option ssid 'myssid'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'sta'
        option bssid '00:11:22:33:44:55'
        option key 'aaaaaaaaaa'

cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option output 'ACCEPT'
        option input 'ACCEPT'
        option forward 'ACCEPT'
        option network 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'
        option src 'wlan0zone'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'
        option enabled '0'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'
        option enabled '0'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'
        option enabled '0'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'
        option enabled '0'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'
        option enabled '0'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'
        option enabled '0'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'
        option enabled '0'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'
        option enabled '0'

config include
        option path '/etc/firewall.user'

config zone
        option output 'ACCEPT'
        option name 'wlan0zone'
        option family 'ipv4'
        option input 'ACCEPT'
        option forward 'ACCEPT'
        option network 'wwan'

config forwarding
        option dest 'wlan0zone'
        option src 'lan'

config forwarding
        option dest 'lan'
        option src 'wan'

config forwarding
        option dest 'wlan0zone'
        option src 'wan'

config forwarding
        option dest 'wan'
        option src 'lan'

config forwarding
        option dest 'lan'
        option src 'wlan0zone'

config forwarding
        option dest 'wan'
        option src 'wlan0zone'

No need to have a "wwan" network unless you're running dual WANs. Modify the default wan to be wireless.

Should be option hostname 'myroutername' to advertise a name to the DHCP server.

Remove this.

2 Likes

It worked. I had to remove it in the config file. With luci, this value is rewritten?

1 Like
1 Like

Thanks for the solution :slight_smile:

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.