Can't mount the USB[solved]

|Model|Linksys WRT1900ACS|
|Architecture|ARMv7 Processor rev 1 (v7l)|
|Firmware Version| SNAPSHOT r16225-0f7cd97f81 / LuCI Master git-21.060.51374-cd06e70|
|Kernel Version|5.4.105|

I have a problem I can't mount this USB stick .

there's no partition table ?

sda is usually the device, sda1 is the 1st partition.

brw-rw---- 1 root disk 8, 0 Feb 12 18:43 /dev/sda
brw-rw---- 1 root disk 8, 1 Feb 12 18:43 /dev/sda1
brw-rw---- 1 root disk 8, 2 Feb 12 18:43 /dev/sda2
brw-rw---- 1 root disk 8, 3 Feb 12 18:43 /dev/sda3

the stick is formatted in exfat and I have no special partition

in that case, you should use mkfs /dev/sda not /dev/sda1

or create a partition :wink:

yes but the ls -al / dev / sd * command doesn't look
I have used this stick before and I have not had these problems

I'm confused, it's right there, in your screen shot ?

or is that another device ?

yes it is the screenshot with my device

then I really don't understand the issue ....

it's there, it's detected/found, and you're trying to create a file system on a non existing partition ...

I formatted the ext4 stick and I will receive the same error

what "same error" ?

The only errors we've seen so far, have been user errors ....

so far I have been following this tutorial and everything worked as in the image in the tutorial

next time you might want to start with that --^

Still not an error, just your disk not matching the layout of the one in the wiki.


but why do I only have the sda1 partition ?

You have formatted the entire block device.
There are no partitions.
Perhaps, it was like this from the beginning.

1 Like

it's your device, not mine .... and you're overthinking this.

at least not any more ... :wink:

1 Like

thanks for the tips, you can close this section !

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.