Cant manage to get connection with router after flashing WRT3200ACM

Hello,
I am new to OpenWRT but not to flashing routers, have run both DD-WRT and Tomato for many years.
Last thunderstorm hit my home network badly and I have bought a new router, Linksys WRT3200ACM, that I intend to flash with OpenWRT.
This question is only about what next steps should be to make it work. Couldn't find a thread that answered me.

After flashing, having carefully read all instructions and tutorials on the OpenWRT site, I ended up in a limbo with the router being non accessible with 192.168.1.1.
However it was identified as 192.168.1.1 from both W10 and Ubuntu desktops when scanning the LAN.

I downloaded the .img file again and double checked the SHA sum etc but again no success in connecting from desktop.

Cabled LAN, WAN connected via a bridged ISP gateway/router (Technicolor) before the WRT3200ACM switch (TP-Link 8 port) between router and desktop PC.

Here is where I get lost as there is no error messages or anything to go on as I cannot access the router at all after flashing.

So I reverted to OEM FW to keep the family at bay. :slightly_smiling_face:

It would have been lovely to have a checklist with do this and do that, but I haven't found one.

What to do? Except from maybe trying DD-WRT?

Many thank in advance!

What file did you exactly install? Snapshot releases do not include a graphical interface, you will have to connect using SSH, and install a stable release, or the graphical interface for your version.

If the ISP's device is also configured on the 192.168.1.1 network, you are going to have issues; disconnect the WRT3200ACM router from the ISP's device, try to connect to it, and configure it on another network.

If everything else fails, you can try to jump back to the vendor's firmware: switch the router off, then on again, but do not let it boot completely; repeat three times, the bootloader will detect a faulty firmware, and switch back to the previous firmware.

Ok, apologize for not being as detailed as I should have been. My bad. :slight_smile:

However, the procedure I followed was what i described here:
https://openwrt.org/docs/guide-quick-start/factory_installation

I fetched the imgage file to use via:
https://openwrt.org/toh/start
and then
https://openwrt.org/toh/hwdata/linksys/linksys_wrt3200acm

I selected the file:
Firmware OpenWrt Install URL:
http://downloads.openwrt.org/releases/19.07.4/targets/mvebu/cortexa9/openwrt-19.07.4-mvebu-cortexa9-linksys_wrt3200acm-squashfs-factory.img

Installation page ends with :
4. Wait while the device writes the firmware image to its flash memory. This can take several minutes (the Device Page may state an expected time for this process). At the end, the device will reboot automatically.
5. The new firmware has been installed.

And next step should have been this:
https://openwrt.org/docs/guide-quick-start/walkthrough_login

And this is where I can't connect from browsers even if 192.168.1.1 is detected.

please try unplug the ethernet cable for a few seconds
can you ssh to the device?
if not that is a DHCP problem
also you cat try to set a static address to your pc

Nothing to apologise for...

You installed a stable release, so the graphical interface should be available out of the box.

I would follow @bricco1981's advice, and unplug the ethernet cable, so the computer detects the disconnection and requests an IP address from the router.

You did not confirm or deny whether the ISP's router is configured on the same 192.168.1.1 network; this is critical.

When you say you cannot connect from browsers even if 192.168.1.1 is detected, what do you mean exactly? What do you see on the browser?

Thanks for helping out I will apply you wise words and make a new attempt and hopefully come back and close this thread.
Hear you in a day or two, with wife working from home and daughter studying at uni from home I need to find the proper time slot for this exercise.

The ISP gateway/router is bridged and should not appear in the LAN. The 192.168.1.1 Linksys was detected by network scanner option in Eset internet security.
But I will of course make sure it will be out of play next time.

Today I made a new attempt, to no avail.

  1. Disconnected router from WAN and LAN
  2. Connected to one PC from patch panel to LAN on router
  3. Linksys firmware/UI worked perfectly.
  4. Switched to upgrade screen in UI and selected .img on PC
  5. Img file processed and "please wait message in UI"
  6. On message (in Linksys UI) "router cannot be reached" I typed in 192.168.1.1 in browser and received a "server can not be reached" message.
  7. Browser cache cleared. Network card restarted
  8. No ping connection either.

Can it have to do with proxy settings or https or something else? FW maybe? Browser is Firefox.

EDIT: not sure if static IP is enabled on PC, but it should be and I will confirm

EDIT II: I recently upgraded from 18.04 to 20.04 and it seems static settings were unset. I will set
Address: 192.168.1.xxx
Netmask: 255.255.255.0
Gateway: 192.168.1.1
and try again later today.

Static IP no difference. Slightly different ping error from before: no connection. ssh no connection either on p22.

EDIT:
read about 30-30-30 method, but that shouldn't have any impact and besides it is strongly emphasized to avoid it with WRT routers

:sweat_smile: :rofl: :joy: :blush:
It worked like a charm when I tried again, from the beginning once i discovered that oops did I really download the 32x ...
With the correct file, no issues. And I also remembered my altered ssh port settings.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.