Can't make GRE Tunnels working in GNS3

I am trying to learn OpenWRT and I think I will go insane.

For some reason tunneling completely fails (based on configs in https://openwrt.org/docs/guide-user/network/routing/examples/routing_in_gre). Just in case (to eliminate reachability problem) I use directly connected routers.

Router 1 Config

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd45:cd6a:ba24::/48'

config interface 'mgmt'
	option device 'eth0'
	option proto 'dhcp'

config interface 'wan'
	option device 'eth1'
	option proto 'static'
	option ipaddr '10.12.12.1'
	option netmask '255.255.255.0'

config interface 'wan6'
	option device 'eth1'
	option proto 'dhcpv6'

config interface 'gre1'
	option proto 'gre'
	option ipaddr '10.12.12.1'
	option peeraddr '10.12.12.2'
	option ttl '255'
	option mtu '1400'

config interface 'mygre'
	option proto 'static'
	option device '@gre1'
	option ipaddr '176.16.12.1'
	option netmask '255.255.255.0'

Router 2 config

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd45:cd6a:ba24::/48'


config interface 'mgmt'
	option device 'eth0'
	option proto 'dhcp'

config interface 'wan'
	option device 'eth1'
	option proto 'static'
	option ipaddr '10.12.12.2'
	option netmask '255.255.255.0'

config interface 'wan6'
	option device 'eth1'
	option proto 'dhcpv6'

config interface 'gre1'
	option proto 'gre'
	option ipaddr '10.12.12.2'
	option peeraddr '10.12.12.1'
	option ttl '255'
	option mtu '1400'

config interface 'mygre'
	option proto 'static'
	option device '@gre1'
	option ipaddr '176.16.12.2'
	option netmask '255.255.255.0'

lsmod | grep gre:

gre                    12288  1 ip_gre
ip_gre                 24576  0 
ip_tunnel              24576  1 ip_gre

ifstatus lists for both interfaces

	"errors": [
		{
			"subsystem": "interface",
			"code": "NO_DEVICE"
		}
	]

Calling 'ip link' on both gre interfaces results in "Cannot find device".
I can ping both wan interfaces from both routers.

I probably miss something obvious, but I have no clue what it can be.
Open WRT version is 23.05.0-4.

Thanks for help.

"device" is physic`l device, luci-proto-gre can help with better configs...

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Wireless and DHCP for LAN are not used since this is a lab in GNS3, I am testing the tunnels on the router itself.
/etc/config/network is already pasted in the previous post

ubus call system board (the same output on both routers)

{
	"kernel": "5.15.134",
	"hostname": "OpenWrt",
	"system": "QEMU Virtual CPU version 2.5+",
	"model": "QEMU Standard PC (i440FX + PIIX, 1996)",
	"board_name": "qemu-standard-pc-i440fx-piix-1996",
	"rootfs_type": "ext4",
	"release": {
		"distribution": "OpenWrt",
		"version": "23.05.0",
		"revision": "r23497-6637af95aa",
		"target": "x86/64",
		"description": "OpenWrt 23.05.0 r23497-6637af95aa"
	}
}

cat /etc/config/firewall (the same output on both routers)

config defaults
	option syn_flood '1'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config zone
	option name 'mgmt'
	list network 'mgmt'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config rule
	option src 'lan'
	option target 'ACCEPT'
	option proto 'tcp'
	option dest_port '22'
	option name 'Allow-SSH'

config rule
	option src 'wan'
	option target 'ACCEPT'
	option proto 'tcp'
	option dest_port '22'
	option name 'Allow-SSH'

config zone
	option name 'gre_zone'
	option network 'gre1 mygre'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'