Can't make bridged AP work

Hi,

first: Thanks for such an amazing OS like OpenWrt and a great community .I am pretty new on OpenWrt and sadly couldnt find any solution for my issue. I desperately try to configure a bridget AP. I do have a (non OpenWrt) base station connected to the internet and serving 2.4 and 5Ghz Wifi access (with DHCP enabled) to any LAN/WIFI clients. This works fine. No issue on that end. On the other end i do have a WL-755 dual band wall-plug wireless router/range extender with a 2.4 and 5Ghz radio + two 100Mbps Ethernet ports. The device had its own OEM firmware, but i flashed the box with the latest OpenWrt (OpenWrt 21.02.1 r16325-88151b8303 / LuCI openwrt-21.02 branch git-21.327.65561-7f37a58) and managed to connect to the base station on the 5Ghz band. Both Ethernet ports (LAN and other is named as LAN/WAN ports on the device surface) are attached as bridge ports to the br-lan device and are served from the LAN interface (attached to br-lan) with DHCP (own subnet, differs from the base station!). The entire box successfully connects to the base station. Both Ethernet ports will be served successfully with their own IP addresses (from the OpenWrt LAN interface) and can access the internet over the 5Ghz radio device. Works fine so far. The IPv6 stuff has been disabled on the box, since i do run a IPv6 network only (service provider end excluded here). Also the OpenWrt WAN and WAN6 interfaces have been deleted. I dont have any use for them.

So here comes the question: How do i make the box act as an Bridget AP to the base station, so the clients will actually get an IP address from the wired host router via WIFI and not the OpenWrt LAN interface? One important reason for this is broadcast traffic. It should work on a LAN network in Bridget AP mode. The current configuration connects via 5Ghz to the base station. The 5Ghz (wlan1 device) runs on a DHCP client interface and gets its own IP from the base station. Thats fine so far. But all wired clients attached to the Ethernet ports will get the different subnet IP address from the OpenWrt LAN interface (br-lan with attached ath0.1 and eth0.2). Anything connected to the Ethernet ports should get their IPs from the base station and should be able to communicate directly to the base. There is only a LAN (br-lan) and WWAN (wlan1) interface left. Config files will be attached later.

I found this tutorial, but didnt manage to adapt it on my configuration.

Pretty sure its kinda easy, but i really didnt manage to make it work. The only thing that i managed to do, is to lock my self out of the box with bad configurations and had to reset it countless. Thats really frustrating after some time. Here is what my current network and wireless config (without any Bridged AP config attempts) files look like:

network:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc3:994c:e63f::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        option ipv6 '0'
        list ports 'eth0.1'
        list ports 'eth0.2'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'eth0.2'
        option macaddr 'xx:xx:xx:xx:xx:xx'
        option ipv6 '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

config interface 'wwan'
        option proto 'dhcp'
        option device 'wlan1'

config device
        option name 'eth0'
        option ipv6 '0'

config device
        option name 'eth0.1'
        option type '8021q'
        option ifname 'eth0'
        option vid '1'
        option ipv6 '0'

config device
        option name 'wlan1'
        option ipv6 '0'

wireless:



config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/10300000.wmac'
        option htmode 'HT20'
        option disabled '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option cell_density '0'

config wifi-iface 'wifinet2'
        option device 'radio1'
        option mode 'sta'
        option network 'wwan'
        option ssid 'Some-SSID'
        option encryption 'psk2'
        option key 'SomeKey'

I really dont know how to adopt that tutorial mentioned above to my configuration files :frowning:

Btw, device looks like this (EU and US versions slightly differ on case size and color):

http://www.win-star.com/en_us/product/WS_WN577A2.html

Thanks for any help.

K.

The best solution would be to use WDS, if the ISP router supports it. Then you can bridge the WDS station to the lan interface.
The next solution would be to use relayd.

Hi, there. As @trendy suggested that Bridge AP configuration you refer to doesn't applies to you. You have 2 options:

  1. WDS
  2. 802.11s

Sadly, there are very high probabilities that OpenWrt implementation and your propietary router's firmware doesn't play well with each other. Most vendors who implement WDS do their own thing and 802.11s is not so extended as we would like.

Hi trendy and amteza,

thanks for the reply. WDS wont be supported by the ISP router (a german Telekom based Speedport 724V) and sadly no Mesh support neither. The relayed option works just fine. The attached LAN devices on the WL-755 will get a IP from the base router. Regular traffic works as expected. The next issue i am faced with is the so called "Media Receiver" (Telekom based Media Receiver 401). Thought the relayed option would work out of the box with the IP TV stuff But it doesnt. Booting and connecting the Media Receiver using the WL-755 over relayed works with no unexpected behaviour. After successfully booting, every channel opens just fine at first but starts to stutter after ~10 seconds and finally the video stops. Afaik this is related to a mixup with IGMP, UDP, Unicast to Mullticast. This is the same issue others faced as described here:

https://forum.openwrt.org/t/solved-iptv-igmpproxy-and-firewall-issues/12890

https://forum.openwrt.org/t/need-howto-for-deutsche-telekom-magenta-tv-and-media-receiver-401/33330/3

I found a general tutorial on this IPTV topic with UDP/Unicast/Multicast with OpenWrt:

https://openwrt.org/docs/guide-user/network/wan/udp_multicast

Currently i wasnt able to make it run successfully.

thank you for your reply

K.

My experience with relayd in the past is very negative, no doubt it should be the last option. After reaching this point why not just utilise a pair of dumb APs disabling your ISP router or, just in case, you cannot put your ISP router in bridge mode go with double NAT, I reckon it will be better than keep utilising relayd and facing its performance penalties and collateral issues.