Can't login via gui, but can ssh

I have a Linksys WRT32X and had 19.07.01 and started showing issues to where I couldn't login. Then I used a davidc502 image and things started working, but then started getting really wonky. So now I just did a sysupgrade from the command line and now have the following version installed ...

Powered by LuCI openwrt-19.07 branch (git-20.247.75781-0d0ab01) / OpenWrt 19.07.3 r11063-85e04e9f46

The problem is I can't login via the web interface. I can however, login via ssh.

I tried root with no passwd, as well as my set password, but neither worked.

Anyone have ideas how to get past this?


I removed luci from CLI, then reinstalled it. Then installed luci-ssl-openssl and can now login via web interface, but there's no data on the pages. If I go to Overview, lots of question marks appear where there should be data.

Should I do an install of the OpenWRT factory instead of the upgrade even though I'm running an OpenWRT image now? Would that rewrite everything on the fs?

Factory and sysupgrade images have the same functionality, so there would be no difference. ( Factory image is compatible with OEM flash tools, but otherwise there is no difference)

You may have carried some incompatible settings in your sysupgrades, as you have tried various builds with different contents.

You should reset the router, so that your settings get cleared. And do not restore config, just reconfigure by hand.

Ps. The next maintenance release 19.07.4 has just been compiled. It will be released in 1-2 days. (Can be downloaded already now). You might also sysupgrade to it without keeping settings. That would to the same as reset.


Like @hnyman said, try this version
and uncheck keep settings when applying but keep a backup of the settings.
Everything will reset to default so make sure you have physical access to the router before doing so.
Start configuring everything back again but in small steps and without installing additional packages to make sure that no packages were causing your problems.
You can always peek inside the backup archive incase you can't remember one of the settings.
And Good luck.


Whenever LuCI gets odd, try clearing the browser cache.


Well, I did the upgrade to 19.07.4 via the CLI using "-v -n" options because the web page wasn't showing up. Anyways, I can no longer access anything via ssh or the web page. I tried my subnet along with the 0 and 1 subnets to no avail.

Then I tried resetting the router with the button on the back. That too was a nogo. Thoughts?

Use the power button to go back to the other partition and from CLI
sysupgrade -F -n image.bin
seems the .4 release should require to be forced I think.

I used the power button to go back to the other partition and that worked. Then I added the -F option to the sysupgrade. Afterwards, same results, I was unable to ping it or log in. I tried my setup subnet, and the 1 subnet.

I then did the power button to go back and I can at least login and view messed up web pages (pages that don't load with data).

ping to your new install yields no response.

Edit: another option depending on how you got the working image, you could maybe try a firstboot to reset device to OOTB settings on that image.

What was the last version that worked well for you? did the 18.06.x release work well for you before? or did you just start with 19.07.x?

@anomeome - correct,, no response.

@Handyman - I can't recall which 18, but I did have an 18 before going to either a 19.07.0 or 19.07.1. Then after a while (I did place it on another network), I would login to a web page and after a few seconds, get a bad gateway address, couldn't view any of the pages from the GUI. Then went to a dc502wrt image, that didn't' go well. Then tried the a 19.07.03 and now a 19.07.04.

IIRC, the early 19.07's worked fine for me.

What I am saying is to try the last stable version that worked well for you with a working luci gui and go from there.
If nothing else works, as a last measure you can go back to stock firmware then make sure that everything working fine and stable before re-flashing OpenWrt.
That last measure seems to fix most unexplainable problems.

Is there a way to load the stock firmware if the luci gui is not showing up? I'm assuming I can't use sysupgrade on the stock firmware.

If I try to go to any link in the menu of the "overview" page, I get "Bad Gateway The process did not produce any response."

tftp via serial connection.

Ok, I'll have to put one on order. In the mean time I'd like to try something else.

Is there a way to uninstall all packages and clean things up to the bare minimum? I can log in to my only working partition, but can't use the GUI. So I'd like to uninstall everything and then try to reload w/o losing my ssh connection. Possible?

Is it ok to use 'list-installed' and try removing each of those in hopes of not removing the ssh (ssl?) packages, and then reinstalling those?

I would suggest firstboot if you have not tried it yet. And I suppose another image may be worth a try; there are some to be found off the link on my avatar, and iirc hnyman may have wrtpac images to be found hereabouts.

When you say firstboot, I assume your talking about a factory image? I have tried that. I guess I can try again, but it's likely it won't work. And if you mean adding stock firmware on, I have no way to load that till my cable arrives.

No. using ssh on the image that you can get into just type firstboot, it resets that image to whatever is in the ROM for setting up an image, as if you are flashing for the first time. see firstboot

1 Like

Oh well, it's toast. I'll just have to wait for a cable and in the meantime, use the ACS.

Thanks for all ya'll's help.

That's a shame. Out of curiosity did you ever load one of the stop-gap images before the _venom_support was officially released. Was actually a rango image massaged to work (convert) and run the venom.

I very well could have. I bought the 32X just as soon as I heard images were working for it and I follow them within a month of release. But then, my memory doesn't work like it used to. It's likely I did install a rango image (back then) because I don't use the wifi with this one.