Can't load libcomposite module

I'm trying to create a custom usb ethernet device using the CDC ECM Ethernet device example from the USB Guest Configuration.

What happened to the libcomposite module? I tried to load it through script and manually with"modprobe libcomposite", but keep getting "failed to find a module named libcomposite". I have kmod-usb-lib-composite installed, and can find the module in /etc/modules.d/50-usb-lib-composite. When I do a search for libcomposite.ko, nothing shows up. How can I load this module?

What does opkg files kmod-usb-lib-composite return?

1 Like

Thanks for responding!

It says it's installed on root and has the following files: /etc/modules.d/50-usb-lib-composite. I tried creating a symlink to modules-boot, but that didn't do anything.

I got it working with the default modules kmod-usb-dwc2 and kmod-usb-gadget-eth(g_ether), and no need for a custom configfs script that I needed for debian.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.