Can't install wpad-openssl patch: ghost hostapd package conflicts

Okay so I'm using OpenWrt 22.03.4, r20123-38ccc47687 on a GL-XE300, and would like to apply my personnal patch of wpad-openssl (wpad-openssl_2022-01-16-cff80b4f-16.2_mips_24kc.ipk), at first I was met with:

root@OpenWrt:~# opkg install wpad-openssl_2022-01-16-cff80b4f-16.2_mips_24kc.ipk
Installing wpad-openssl (2022-06-02-4383528e-14) to root...
Collected errors:
 * check_conflicts_for: The following packages conflict with wpad-openssl:
 * check_conflicts_for:         hostapd * check_conflicts_for:  wpad-basic-wolfssl *

So I tried removing every package related to wpad / hostapd:

root@OpenWrt:~# opkg remove hostapd-common hostapd-utils wpad-basic-wolfssl
[success]
root@OpenWrt:~# opkg list-installed | grep -E '(hostapd|hostapd-mini|hostapd-openssl|hostapd-wolfssl|wpad|wpad-mesh-openssl|wpad-mesh-wolfssl|wpad-mini|wpad|wpad-mesh-openssl|wpad-mesh-wolfssl|wpad-mini)'
(nothing)

However, after a reboot to make sure no packages were left, the list-installed/grep is still clear, but I continue to get:

root@OpenWrt:~# opkg install wpad-openssl_2022-01-16-cff80b4f-16.2_mips_24kc.ipk
Installing wpad-openssl (2022-06-02-4383528e-14) to root...
Collected errors:
 * check_conflicts_for: The following packages conflict with wpad-openssl:
 * check_conflicts_for:         hostapd *
 * opkg_install_cmd: Cannot install package wpad-openssl

With force, I'm met with a "Package wpad-openssl is not available from any configured src." / "failed to download", which is weird since I'm providing the .ipk:

root@OpenWrt:~# opkg install wpad-openssl_2022-01-16-cff80b4f-16.2_mips_24kc.ipk --force-overwrite --force-depends
Installing wpad-openssl (2022-06-02-4383528e-14) to root...
Collected errors:
 * opkg_download_pkg: Package wpad-openssl is not available from any configured src.
 * opkg_install_pkg: Failed to download wpad-openssl. Perhaps you need to run 'opkg update'?
 * opkg_install_cmd: Cannot install package wpad-openssl.

Any idea how I could fix this? I obviously tried opkg update.
This is the content of my /usr/lib/opkg/status:

root@OpenWrt:~# grep -C8 hostapd /usr/lib/opkg/status
Provides: libsqlite3
Status: install ok installed
Architecture: mips_24kc
Installed-Time: 1685536211
Auto-Installed: yes

Package: wpad-openssl
Version: 2022-06-02-4383528e-14
Depends: hostapd-common (= 2022-06-02-4383528e-14), libc, libnl-tiny2022-05-17, hostapd-common, libubus20220601, libopenssl1.1
Provides: hostapd, wpa-supplicant
Conflicts: hostapd, hostapd-basic, hostapd-basic-openssl, hostapd-basic-wolfssl, hostapd-mini, hostapd-openssl, hostapd-wolfssl, wpad, wpad-mesh-openssl, wpad-mesh-wolfssl, wpad-basic, wpad-basic-openssl, wpad-basic-wolfssl, wpad-mini, wpad, wpad-mesh-openssl, wpad-mesh-wolfssl, wpad-basic, wpad-basic-openssl, wpad-basic-wolfssl, wpad-mini
Status: install prefer not-installed
Architecture: mips_24kc

Package: wpad-openssl
Version: 2022-01-16-cff80b4f-16.2
Depends: hostapd-common (= 2022-01-16-cff80b4f-16.2), libc, libnl-tiny1, hostapd-common, libubus20220601, libopenssl1.1
Provides: hostapd, wpa-supplicant
Conflicts: hostapd, hostapd-basic, hostapd-basic-openssl, hostapd-basic-wolfssl, hostapd-mini, hostapd-openssl, hostapd-wolfssl, wpad, wpad-mesh-openssl, wpad-mesh-wolfssl, wpad-basic, wpad-basic-openssl, wpad-basic-wolfssl, wpad-mini, wpad, wpad-mesh-openssl, wpad-mesh-wolfssl, wpad-basic, wpad-basic-openssl, wpad-basic-wolfssl, wpad-mini
Status: install user not-installed
Architecture: mips_24kc

Package: tcpdump
Version: 4.9.3-4
Depends: libc, libpcap1
Status: install user installed
Architecture: mips_24kc
--
Depends: kernel (= 5.10.176-1-5c9be91b90bda5403fe3a7c4e8ddb26f), kmod-crypto-lib-chacha20poly1305, kmod-crypto-lib-curve25519, kmod-udptunnel4, kmod-udptunnel6
Status: install ok installed
Architecture: mips_24kc
Installed-Time: 1684315930
Auto-Installed: yes

Package: kmod-mac80211
Version: 5.10.176+5.15.92-1-1
Depends: kernel (= 5.10.176-1-5c9be91b90bda5403fe3a7c4e8ddb26f), kmod-cfg80211, kmod-crypto-cmac, kmod-crypto-ccm, kmod-crypto-gcm, hostapd-common
Status: install user installed
Architecture: mips_24kc
Installed-Time: 1681043266
Auto-Installed: yes

Package: wireguard-tools
Version: 1.0.20210424-3
Depends: libc, kmod-wireguard
--
Version: 1.46.5-2
Depends: libc, libcomerr0
Provides: libss
Status: install ok installed
Architecture: mips_24kc
Installed-Time: 1684251159
Auto-Installed: yes

Package: hostapd
Version: 2022-01-16-cff80b4f-16.2
Depends: hostapd-common (= 2022-01-16-cff80b4f-16.2), libc, libnl-tiny1, hostapd-common, libubus20220601
Status: install user not-installed
Architecture: mips_24kc

Try removing the conflicting package using the online image builder (this might however remove additional packages, due to dependencies), then install yours post flash.

I'm clearly no expert, but why would this be different from removing packages ? I can remove relative kmods too, but apart from config files nothing should stop me from installing this right?
I'll try to reinstall a custom image but probably as a last resort since this is an extroot + lots of post flash customization