Can't install the upnp package

I got the following message when I try to install luci-app upnp module :

    **Details for package luci-app-upnp**

**    Version: git-19.183.27706-2d1d855-1**
**    Size: ~3.6 KB installed**
**    Dependencies:**
**        miniupnpd (55.7 KB) Not installed**
**            iptables Installed**
**                libpthread Installed**
**                    libgcc1 Installed**
**                kmod-ipt-core Installed**
**                    kernel Installed**
**                    kmod-nf-reject Installed**
**                    kmod-nf-ipt Installed**
**                libip4tc0 Installed**
**                    libxtables12 Installed**
**                libip6tc0 Installed**
**            libip4tc2 Not available**
**            libip6tc2 Not available**
**            ip6tables Installed**
**                kmod-ip6tables Installed**
**                    kmod-nf-reject6 Installed**
**                    kmod-nf-ipt6 Installed**
**            libuuid1 (12.1 KB) Not installed**
**                librt (124 B) Not installed**

**Required dependency package libip4tc2 is not available in any repository.**
**Required dependency package libip6tc2 is not available in any repository.**

What are these packages?

libip4tc2 and libip6tc2

Which device is that and which version of OpenWrt are you running?
If it is a snapshot, you need to install any additional packages in the same day, before the nightly compile changes them.

1 Like

This version of "Openwrt"

2019 June version of this firmware

and which device?

That is not the official OpenWrt but somebody's private build. And it is a month old...

He has not refeshed & compiled his build after iptables was bumped to 1.8.3 (causing the possible dependendies to iptables 1.8.2 modules like libip4tc2 to be invalid)


Tplink WR1043 ND version 2.1

Okay :face_with_head_bandage:
But I tried to install an older version of luci-app-upnp and it was also had got a problem with libip4tc2 (module)
Why was it? Because older version was worked for a while I was on another firmware version.

The build you reference is based on a custom, heavily modified, older master snapshot. The "custom, heavily modified" part implies that it's already questionable to which extent you can match and mix packages from official OpenWrt in the first place. Given that master, contrary to fixed stable releases, is a moving target, implies that "older master" often quickly means that packages become incompatible over the course of time, due to library updates (different SONAMEs/ library ABIs), package relations changing or packages going away completely. On-flash size (complex package meta data is expensive, both in terms of flash requirements and RAM requirements for the package manager to come up with a dependency solution) and manpower limit the amount of interoperability OpenWrt can provide for mixing packages from different (or detached, read older) branches.

1 Like