Cant install package openvpn_openssl (snapshot)

Im using a td-w8960n v5 router with a image from https://openwrt.org/toh/tp-link/tp-link_td-w8960n_v5 and i cant install openvpn_openssl using luci or opkg. I get a error:

root@OpenWrt:~# opkg install openvpn-openssl
Installing openvpn-openssl (2.3.11-1) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/brcm63xx/generic/packages/base/openvpn-openssl_2.3.11-1_brcm63xx.ipk.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for openvpn-openssl:
 *      kernel (= 4.4.14-1-c5c62e69328c6ed78d1d143a5c96f0c3) *
 * opkg_install_cmd: Cannot install package openvpn-openssl.

If i need to compile it can someone provide me with some instructions.

this is because of snapshot release being used.

but is there a way of installing/compiling it on snapshot release or i need to somehow get a stable on my router?

stable, or get the most recent snapshot available, additional packages are then installable during a <24h window, until next snapshot is released, or make a full dump of the package repository.

RCs will work too, RC3 and RC4 have luci preinstalled.