Can't install OpenWrt to ASUS RT-AC57U

Tried to install openwrt-21.02.3-ramips-mt7621-asus_rt-ac57u-initramfs-kernel.bin following the instructions on the wiki.

All was going well until the reboot after mtd-write -i /tmp/owrt.bin -d linux

Router restarted and the blue power light was just flashing really fast for about 20 minutes.

Thought something wasn't correct as a firmware update doesn't take that long.

Powered off and back on and still the same fast flashing power light.

Tried to install ASUS firmware back using the rescue tool, following the instructions about putting in rescue mode and setting IP address, but it just says that the router isn't in rescue mode.

Where do I go from here?

Instructions state to install the sysupgrade.bin image.

Transfer the OpenWrt sysupgrade image via scp. (Windows users can use WinSCP to copy owrt.bin file to /tmp folder)

I installed 21.02.3 on my RT-AC57u v1 a few days ago,

When the router is in Rescue mode, I believe the Power LED blinks slowly.
If you are using 3rd party security software on your Windows computer, try turning it off. Try using a different Windows computer with built in ethernet socket.

I just realised there is a newer Firmware restoration tool. It seems to have shrunk in size compared to previous version.

I use the older version without problems to restore Asus OEM firmwares to my RT-AC57u v1 and RT-AC85P with my Windows 10 laptop.

1 Like

Thanks got it sorted. Used a windows PC without any security software to flash the ASUS image - worked first time.
Then used the proper OpenWrt image this time.

1 Like

Please mark as Solved.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.