Can't install OpenWrt firmware in TP-Link TL-WR940N BR

Hello!

I'm trying to install the OpenWRT firmware version 18.06.1 on the router TL-WR940N BR, and am getting the error:
Error code: 18005
The update failed due to the incorrect version of the updated file. Check the file name.

On the page indicates that the firmware is compatible with the BR version.
can anybody help me? I'm following exactly the instructions on the page
https://openwrt.org/docs/guide-quick-start/factory_installation

Thanks

I'm not sure where on your link there is any mention of that router or version. It looks to be a generic page.

https://openwrt.org/toh/tp-link/tl-wr940n appears to be the device-specific page.

That said, you're going to have a terrible time with any device with only 4 MB of flash and 32 MB of RAM.

https://openwrt.org/supported_devices/432_warning

Hello Jeff! Thank to your answear.

I looked the page Generic Install, and tried the first method for now. And I was thinking if don't exist same part didn't show in this page.

The router is right to be a TFTP client or isso necessary same configuration first?

Sorry, I'm new with that :confused: