Can't Install OpenWrt EAP245v1

I've been following the (quite rough for a brand new user) instructions for installing OpenWRT on a tp-link EAP245v1 from the commit adding support. I've followed through all the steps until I'm told to 'Extract /usr/bin/uclited from the device via ssh'. I've installed Putty and WinSCP to access the AP remotely, but then I ran into the following:

Whenever I try to do anything to /usr, I get a read-only file system error. This means I can't do anything to the uclited file. Additionally, WinSCP is unable to copy files from the AP because it's unable to connect to the telnet/root port, and therefore doesn't have permission to use scp (I could probably get around this second issue by just using pure shell commands though I'd need to do more research).

chmod 777 on usr gives me the same error. I don't really know what to do at this point and any help would be much appreciated. Right now even if I figure out how to copy the uclited file to my local machine, I can't actually paste the edited vesion back.

which step fails, specifically ?

* Use the root shell via telnet to make /tmp world writeable (chmod 777)
* Extract /usr/bin/uclited from the device via ssh and apply the binary
  patch listed below. The patch is required to prevent `uclited -u` in
  the last step from crashing.
* Copy the patched uclited programme back to the device at /tmp/uclited
  (via ssh)

Huh, I just realized I'm being an idiot and misunderstood what I will have to do, I don't actually need write access to /usr -_-. Then I just have the more minor problem of not knowing how to move the file to/from the AP because WinSCP can't ssh to the root telnet port, and I'm not sure how to transfer the files via a shell directly, but I'm pretty sure I can figure that out on my own, sorry for wasting your time.

winscp doesn't use telnet for, well, anything ...

scp (and by extention WinSCP) uses the ssh protcol. IIRC the ssh daemon provided on these access points does support this, which is why some juggling with pipes and dd is typically used.

See for example the install instructions for the EAP225 v1/v2 on the wiki:
Aside from the file hashes and the binary patch offset, these instructions can also be used to flash the EAP245v1.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.