Can't get USB on Raspberry Pi CM4 working

Hi good people,

I have a CM4 (Raspberry Pi) and I just cannot get USB to work.
Beforehand; I am aware that CM4 has USB disabled by default and I already enabled it.

  • I followed the "Installing and troubleshooting USB Drivers" through but nothing worked.
  • I tried to reinstall OpenWrt 2 times and still nothing.
  • I installed then Raspberry Pi OS to verify if the hardware is working correctly. Under Pi OS everything is working fine.
  • I watched dmesg while plugging usb device into the Pi and nothing has been reported.

I am currently back to clean install of OpenWrt and have no clue how to proceed anymore.

Here is some initial outputs from different log files etc:

root@OpenWrt:~# opkg list-installed | grep usb
brcmfmac-firmware-usb - 20220411-1
kmod-usb-core - 5.10.138-1
kmod-usb-hid - 5.10.138-1
kmod-usb-net - 5.10.138-1
kmod-usb-net-lan78xx - 5.10.138-1
root@OpenWrt:~# lsusb 
unable to initialize libusb: -99
root@OpenWrt:~# cat /sys/kernel/debug/usb/devices
 ---- Nothing.

Any idea what can I do beside it?

Thanks in advance.


you need libusb for this

if you use the USB port, is there any reaction in dmesg ?
(EDIT: you actually said there wasn't)

1 Like

Yes, because I am now on a clean install. So going to install it first and will report back.


Nope. Sorry, it is installed:

root@OpenWrt:~# opkg list-installed | grep libusb
libusb-1.0-0 - 1.0.24-5

EDIT: I assume it was installed with usbutils

Nobody have an idea??

are you absolutely sure you enabled usb even after reinstallation ?

Well of course a pi can be use for fun to have a light turn on from a web app over a phone. But it's not a router. You can code a driver for the usb and post after.