Can't get serial connection to work with Linksys EA7500

I am trying to flash my Linksys EA7500 running OEM firmware 1.1.2 (as recommended on the install docs). I tried through the webui but got a firmware not supported error, so I bought this 1.8v compatible usb ttl adapter. After setting the jumpers to 1.8v and soldering some jumper wires from the main board as shown in the docs I'm not getting any serial out from the device. I checked my connections and rx/tx both have 1.8v as they should (even with the ttl adapter unplugged) and ground is also working. I have tried various serial softwares including minicom and gtkterm (I'm running arch linux) but none seem to matter. The serial adapter appears to work (atleast in 3.3v mode) as I tried using it with an arduino I have and it read the serial out's just fine. The only thing I can think of is if maybe the shown solder placements are wrong in the docs, or 1.8v is broken on the ttl adapter, I tested 1.8v using loopback by connecting the rx and tx and it worked so seems unlikely and 3.3 works fine with arduino.

triple check pdf about pins on jtag router.

  • pin order

  • pin voltage

  • cables

1 Like

I'm not using the JTAG port, since the doc doesn't give any info for it. I am just using the standard serial debugging port but with 1.8v logic as seen here:https://openwrt.org/_media/media/linksys/linksys_ea7500_v1-uart_1v8.jpg?cache=&w=576&h=600&tok=e3c524

I did triple check order and everything, but I'm not getting a signal even though rx/tx are both raised to 1.8v and ground is connected to other areas of ground the router boots normally just doesn't give me an serial output.

maybe @slh could help

Hopefully, the docs say @ReDaLeRt modified it last so if you have any insights please also share XD

The image given for the serial connector has the RX and TX channels flipped. After flipping them serial works fine at 1.8v... So for anyone else plug rx into the supposed tx and vice versa

1 Like

its always pin order, jtag and serial are very fail proof

unless you connect wrongly by mistake which happens a lot

I checked the connections again and the demo image just shows the rx and tx pins as flipped, so the docs need to be updated

Not necessarily.
It's a point of view...
When - for example - a connector is marked TXD, it could mean either that this is
where the transmit data comes from the device (should be so in most cases) or that you have to connect your TX line from the other device to this point ( i've seen this only once).

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.