Can't get router recovery methods to work (TP-Link Archer C7)

I'm been playing around with a TP-Link Archer C7 including compiling my own v21.03 firmware for it. Unfortunately the other day I managed to kick myself out of the router.

Usually in this situation I would hold down the reset button to perform a factory reset, however this didn't work. I tried a 4, 10 and 30 second reset button hold but no difference. I then tried to use the failsafe feature by trying to catch the router at the right time during startup but this didn't work either. The only recovery functionality I have is TP-Link's TFTP.

The last time I compiled firmware for this router was v19.07 and the reset button did work. Is there anything I should be checking on the router's system or within make menuconfig to ensure the reset button functionality is included? I have a weird feeling that I've somehow not included the rocovery options in my compiled firmware. Additionally, is the failsafe feature standard to OpenWrt or would it be something I would have to select to be included in the compiled firmware?

Both reset and failsafe features are included by default.

I had to recover from a failed conversion attempt from LEDE. TFTP worked great on the C7 v2.

Instructions are in the TOH page, address for me was

Okay so I've just flashed a stock OpenWrt firmware image to the router eliminating my own compiled firmware and the reset button now works. It turns out the package kmod-gpio-button-hotplug was missing. I have now selected it in make menuconfig under Kernel modules > Other modules.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.