Cant' get into ATT BGW210 Modem/Router combo gateway

Hi, ever since i installed OpenWrt on my WNDR3700v4 i can't get into the gateway for my modem/router combo which is 192.168.1.254, how should i go about this?

Also read something about bridging the modem/combo and dedicated router too but can't get into my modem since gateway won't work.

Also read an article about Double NATTing, is this what i'm doing at the moment?
https://kb.netgear.com/30187/How-to-fix-issues-with-Double-NAT
https://openwrt.org/docs/guide-user/network/switch_router_gateway_and_nat

My setup is internet -> ATT BGW210 (Modem/Router combo) -> Netgear WNDR3700v4 -> PC

Thanks.

  • Renumber your LAN to something other than 192.168.1.0/24
  • Make a route for 192.168.1.254/32 at WAN

Tried to change LAN to 10.0.0.1 since that was what it was before i changed the router firmware. Did not work and caused me to lose connection. Router was locked up, pressed the nipples twice on the router to reset it and got back into router with same settings before i screwed up.
Can you tell me what i should change it to and how should i possibly go about it. Thank you.

I just told you...and you can also change the LAN IP on the command line at /etc/config/network

If that's difficult, you can just add the static route to 192.168.1.254 facing WAN.

  • Are you getting an IP via DHCP; and browsing to the new page within 30 seconds?
  • You do know there's a emergency revert feature, correct?

Im getting a static Ip Address for LAN
WAN is DHCP.
Yes i am browsing to new page within 30 seconds, no i did not know there was an emergency revert feature.

What does that have to do with the solution static route solution I offered?

Are you saying you don't wish to perform the tasks?

What happens when you make a static route to 192.168.1.254 on WAN?

Sorry, its not that i didn't take your offer. I got confused.

# in /etc/config/network

config route
	option interface 'wan'
	option target '192.168.1.254/32'
	option gateway '192.168.1.1'

Hope this helps.

I got past the first line of code then start of
"config route" not found

root@OpenWrt:~# # in /etc/config/network
root@OpenWrt:~# config route
-ash: config: not found
root@OpenWrt:~# option interface 'wan'
-ash: 25option: not found
root@OpenWrt:~# option target '192.168.1.254/32'
-ash: option: not found
root@OpenWrt:~# option gateway '192.168.1.1'

Image of the interface

OK, you need some more guidance...

  • On command like
    • you enter vi /etc/config/network
    • then add what I typed to the bottom
  • OR on the web GUI:

Hope this helps.

FYI, this is not the renumber LAN method. This is the method to put a route saying that 192.168.1.254 is on WAN and not LAN. Successfully renumbering the LAN would make this unnecessary.

I strongly recommend you renumber your LAN. Doing so is tricky because you will lose connection. I'd suggest 10.x.y.0/24 where x and y are both something other than 0, 1, or 10, so for example 10.22.15.0/24, if you set that up, you're unlikely to ever have a conflict with anything else.

when you change this, the router will become unresponsive, wait about 30 seconds, and it will come back and tell you you didn't confirm within the timeout period, and then select to save the config unchecked. After that you can restart your computer's network and should get a DHCP assignment in the new net range.

1 Like

I will try these suggestions in a moment. Thank you.

Only choose one:

@dlakelan and I suggest you choose to simply renumber LAN.