Judders
December 20, 2024, 5:21am
1
Hey Guys. Sorry another newbie here. I just replaced my router with Banana Pi R4 with BPI-BE14 wifi card.
I can connect all my Wifi devices apart from my 2 x Amazon Echos. I have tired every setting under the Wifi settings with still no luck.
Echos can still connect to my old router OK.
Running the latest OpenWrt 24.10.0-rc2. Clean Install.
Nothing in SystemLog about attempting to connect.
Anyone point me in the right direction.... Thanks!
Judders
December 20, 2024, 5:30am
2
config wifi-device 'radio0'
option type 'mac80211'
option path 'soc/11300000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option radio '0'
option band '2g'
option channel 'auto'
option htmode 'EHT20'
option cell_density '0'
option country 'AU'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'Mxxxxxxx'
option encryption 'sae-mixed'
option key 'xxxxxxxxx'
option ocv '0'
config wifi-device 'radio1'
option type 'mac80211'
option path 'soc/11300000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option radio '1'
option band '5g'
option channel '153'
option htmode 'VHT80'
option country 'AU'
option cell_density '0'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'Mxxxxxxx'
option encryption 'sae-mixed'
option key 'xxxxxxxxxx'
option ocv '0'
config wifi-device 'radio2'
option type 'mac80211'
option path 'soc/11300000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option radio '2'
option band '6g'
option channel 'auto'
option htmode 'EHT80'
option country 'AU'
option cell_density '0'
option disabled '1'
config wifi-iface 'default_radio2'
option device 'radio2'
option network 'lan'
option mode 'ap'
option ssid 'XXXXXXX'
option encryption 'sae-mixed'
option key 'XXXXXXXX
option ocv '0'
option disabled '1'
config wifi-iface 'wifinet3'
option device 'radio0'
option mode 'ap'
option ssid 'Mxxxxxxxx3'
option encryption 'psk2'
option key 'xxxxxxxxxxx'
option network 'lan'
1 Like
Judders
December 20, 2024, 7:20am
4
@frollic . Thanks, I should have mentioned I have tried the other options for Wifi encryption. I have even tried no encryption with no luck.
Let's see the rest of the config to see if there are any other things that might be potential culprits:
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </>
" button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
ubus call system board
cat /etc/config/network
cat /etc/config/dhcp
cat /etc/config/firewall
Judders
December 20, 2024, 7:31am
6
{
"kernel": "6.6.63",
"hostname": "OpenWrt",
"system": "ARMv8 Processor rev 0",
"model": "Bananapi BPI-R4",
"board_name": "bananapi,bpi-r4",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "24.10.0-rc2",
"revision": "r28161-ea17e958b9",
"target": "mediatek/filogic",
"description": "OpenWrt 24.10.0-rc2 r28161-ea17e958b9",
"builddate": "1733226068"
}
}
/etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'xxxx:xxxx:xxxx::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth1'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
option ipv6 '0'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.2.1'
option netmask '255.255.255.0'
option ip6assign '60'
config device
option name 'br-wan'
option type 'bridge'
list ports 'eth2'
list ports 'wan'
config device
option name 'wan'
option macaddr '0e:xx:xx:xx:xx:xx'
config device
option name 'eth2'
option macaddr '0e:xx:xx:xx:xx:xx'
config interface 'wan'
option device 'br-wan.10'
option proto 'dhcp'
config interface 'wan6'
option device 'br-wan'
option proto 'dhcpv6'
config bridge-vlan
option device 'br-wan'
option vlan '10'
list ports 'eth2:t'
list ports 'wan:t'
/etc/config/dhcp
config dnsmasq
option domainneeded '1'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option cachesize '1000'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option localservice '1'
option ednspacket_max '1232'
config dhcp 'lan'
option interface 'lan'
option start '210'
option limit '20'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
list ra_flags 'managed-config'
list ra_flags 'other-config'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
config hosts, plenty
/etc/config/firewall
config defaults
option syn_flood 1
option input REJECT
option output ACCEPT
option forward REJECT
config zone
option name lan
list network 'lan'
option input ACCEPT
option output ACCEPT
option forward ACCEPT
config zone
option name wan
list network 'wan'
list network 'wan6'
option input REJECT
option output ACCEPT
option forward REJECT
option masq 1
option mtu_fix 1
config forwarding
option src lan
option dest wan
config rule
option name Allow-DHCP-Renew
option src wan
option proto udp
option dest_port 68
option target ACCEPT
option family ipv4
# Allow IPv4 ping
config rule
option name Allow-Ping
option src wan
option proto icmp
option icmp_type echo-request
option family ipv4
option target ACCEPT
config rule
option name Allow-IGMP
option src wan
option proto igmp
option family ipv4
option target ACCEPT
config rule
option name Allow-DHCPv6
option src wan
option proto udp
option dest_port 546
option family ipv6
option target ACCEPT
config rule
option name Allow-MLD
option src wan
option proto icmp
option src_ip fe80::/10
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family ipv6
option target ACCEPT
config rule
option name Allow-ICMPv6-Input
option src wan
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
list icmp_type router-solicitation
list icmp_type neighbour-solicitation
list icmp_type router-advertisement
list icmp_type neighbour-advertisement
option limit 1000/sec
option family ipv6
option target ACCEPT
config rule
option name Allow-ICMPv6-Forward
option src wan
option dest *
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
option limit 1000/sec
option family ipv6
option target ACCEPT
config rule
option name Allow-IPSec-ESP
option src wan
option dest lan
option proto esp
option target ACCEPT
config rule
option name Allow-ISAKMP
option src wan
option dest lan
option dest_port 500
option proto udp
option target ACCEPT
1 Like
I'm not seeing anything obviously wrong, but....
Judders:
option limit '20'
How many devices are in your network? You have a pool size of just 20 IPs in your DHCP server.
Judders
December 20, 2024, 7:49am
8
Thanks @psherman
I have about 40 devices...
Pool size is 20, All devices have assigned static IPs outside of the pool.
Even both Echos have assigned IP address..
I dont think its getting that far as I cant see connecting in the systemlog, like i see other devices connecting OK.
Echos are also sitting right next to the banana pi!
Maybe reset the echo devices to defaults and see if they will connect with DHCP?
The only other thing to look at is the config of your 2g radio.
HT20 might work better here, if that is an option for your device.
totkeks
December 20, 2024, 8:12am
10
When setting up the echo, do you see the networks in the Alexa app? Or do they not show at all?
And if they see it, check the channels you are using. On 2.4GHz it might be it okay, but on 5Ghz there will be channels that they don't support.
1 Like
Judders
December 20, 2024, 9:22pm
12
I think EHT is correct. I have also tried creating another AP with every N,AC,AX and BE setting. again doesn't make any difference.
Admittedly I have been testing all these setting by creating a new AP and not editing my main AP, Which I am guessing is OK?
@totkeks I have also tried 2.5G and 5G APs. Yes they are showing up in the alexa app.
Have even used a Wifi scanner, and made settings from the router they do connect to the same in WRT.. (Mode, Band, Channel and Width ETC)
Have also defaulted the darn things.
I see I can change the log level I will try that next and hopefully see the initial handshake attemps?
frollic
December 20, 2024, 10:15pm
13
config wifi-device 'radio1'
option type 'mac80211'
option path 'platform/soc/c000000.wifi+1'
option band '2g'
option htmode 'HT40'
option channel '3'
option country 'DE'
option cell_density '0'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'xxxxx'
option encryption 'psk2'
option key 'yyyyy'
works for my Echo show (pre 2024).
brada4
December 20, 2024, 10:54pm
14
If it helps eero provides wpa2+ccmp only.
Judders
December 25, 2024, 4:21am
15
Finally got a chance to get back to this. Used a wireless scanner and set the same config as the old router. ( AC mode, Channel 183, and 80Mhz Width )
Had to set change my main wireless channels, and not just one i added for testing.
HT40 was the answer.
Thank you all for the suggestions. Much appreciated. Wife is happy again!
1 Like
system
Closed
January 4, 2025, 4:21am
16
This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.