Can't get adguardhome service to start

I just set up openwrt on a raspberry pi 4 following the guide below.

I am unable to get adguardhome service to start and its not giving me any errors. Without any error messages I'm not sure where to start. When I googled the issue, all the post that came up with similar issues were getting error messages.

Any help would be appreciated.

Guide used:

|Architecture | ARMv8 Processor rev 3|
|Target Platform | bcm27xx/bcm2711|
|Firmware Version | OpenWrt SNAPSHOT r18067-694aed607f / LuCI Master git-21.301.66258-0740023|
|Kernel Version | 5.10.78|

Check the system log for relevant errors:

1 Like

tried /etc/init.d/adguardhome start ?

After checking the logs I have the same issue as this post: Adguardhome won't start - #5 by IanH

That thread never really found a solution though. It was mentioned that you need ca-certificates, ca-bundle and wolfssl. I have all 3

1 Like

I had to manually install AdGuardHome. Here are the steps I used.
ssh to router

    # cd ~
    # curl -o AdGuardHome.tar.gz
    # gunzip AdGuardHome.tar.gz
    # tar xvf AdGuardHome.tar
    # mv adguardhome /etc/init.d
    # cd /etc/init.d
    # ln -s /etc/rc.d/K89adguardhome /etc/init.d/adguardhome
    # ln -s /etc/rc.d/S21adguardhome /etc/init.d/adguardhome

Now I did this some time ago so the steps might not be accurate. Specifically I recall that at one stage I used my mac to extract AdGuardHome and then copied it via scp to the router. Also the link to AdGuardHome might be out of date.

1 Like

@sdj2005 what version of Openwrt are you running. As far as I can recall, someone mentioned AdGuard Home has a package in the latest firmware. I may be wrong, I'm not using it.

21.02 or 21.02 rc4 of 21.02 rc3.
The dashboard says "SNAPSHOT r17316-5ecd99f7d2"

Sorry not sure. I tried looking in the build directory to find the version but I couldn't find it
I did find this link

which lists 21.02 as r16279-5cc0535800
so I guess it has to be either rc3 or rc4

I wiped the drive and started over with the current stable version but still getting the same issue.
21.02.1, r16325-88151b8303

Not sure what rc3 or rc4 is or how to tell which one I have.

I used opkg to install adguardhome. Version listed is 0.106.3-1.

I was able to get it working by following the first 4 steps of IanH post.

After that I made the directory /root/adguardhome and moved the file there.
Then I added the following lines to the local startup (/etc/rc.local)

cd /root/adguardhome
screen -d -m -S adguardhome ./AdGuardHome

As luck would have it, I needed to install openwrt on my new OrangeOi R1+. The instructions I used above were months old and sdj2005 makes the point correctly that they are outdated. I found a simpler way to set up though. I just copied /root/AdGuardHome to /usr/bin after tar extract and it all worked

want even easier?

Use the 107 edge build. there are a number of horrible issues with AGH below 107. The edge build is far more fixed. the opkg version that is openwrt is 104 and utterly useless.

theres a more recent guide that summerises the old thread.

New thread : OpenWrt AdGuard Home 101 ( DNSMASQ )

older thread : [HowTo] Running Adguard Home on OpenWrt

The new thread i added some issues regarding space and updating. I have open issues filed with AGH team they will add to 107.1.

You also dont need unbound like the poster says. you can do it all via DOH internally to AGH. I've posted a few corrections in the 2nd post.

(AGH github and documentation -

opkg install ca-certificates ca-bundle sudo libustream-mbedtls libustream-openssl libwolfssl libustream-wolfssl luci-ssl px5g-wolfssl wpad-basic-wolfssl luasocket curl libevent2-7 unzip curl wget libmbedtls12 tar tcpdump-mini

(tbh their install script should test for everything it requires and fail out if you dont have the required dependancies but it doesnt. I do keep meaning to do a clean openwrt install and figure out what is missing and file an issue with AGH to check for it but i've been too busy.)

generally its sudo missing that is the issue (it wont install the service otherwise.)

curl -s -S -L | sh -s -- -c edge

Use the 107 edge build. check the two other posts i listed. you can see the history of fixes.

I got AGH team to do some fixes for 107. the 104 version that is in openwrt repository? It installs to /tmp so every time you reboot the router you will have to reset up AGH. Really should be removed.