Can't get 802.11N on 2.4G and change region on WTR1900ACS

So I'm using my linksys WRT1900ACS before with DD-WRT , channel 100 and 802.11N with 256 QAM worked .
I've just siwtched to Openwrt recently and I can't get the country changed in both Luci or Cli.
It is so counfusing to me and what's more worse is that I can't use 802.11 N on 2.4GHz.

Here is some info:

config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11a'
option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
option htmode 'VHT80'
option legacy_rates '0'
option country 'AU'
option channel 'auto'
option noscan '1'

config wifi-device 'radio1'
option type 'mac80211'
option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
option legacy_rates '0'
option hwmode '11g'
option channel 'auto'
option country 'AU'
option noscan '1'
option __toggle 'Enable'
option htmode 'VHT20''

config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option macaddr 'something'
option encryption 'psk2'
option key 'something'
option ssid 'something'
option wmm '0'

config wifi-iface
option device 'radio0'
option mode 'ap'
option encryption 'none'
option disabled '1'
option ssid 'something'

I've tried using with noscan=1 and =0 and tried bunch of country codes , and different htmode on 2.4Ghz and hwmode .But sadly no luck.
Also I can't change the country code on phy 1 and phy 0
global
country 98: DFS-UNSET
(2402 - 2482 @ 40), (N/A, 20), (N/A)
(5170 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
(5250 - 5330 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
(5735 - 5835 @ 80), (N/A, 30), (N/A)
(57240 - 59400 @ 2160), (N/A, 28), (N/A), NO-OUTDOOR
(59400 - 63720 @ 2160), (N/A, 43), (N/A), NO-OUTDOOR
(63720 - 65880 @ 2160), (N/A, 28), (N/A), NO-OUTDOOR

phy#1
country CN: DFS-FCC
(2402 - 2482 @ 40), (N/A, 20), (N/A)
(5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
(5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
(5735 - 5835 @ 80), (N/A, 30), (N/A)
(57240 - 59400 @ 2160), (N/A, 28), (N/A)
(59400 - 63720 @ 2160), (N/A, 44), (N/A)
(63720 - 65880 @ 2160), (N/A, 28), (N/A)

phy#0
country CN: DFS-FCC
(2402 - 2482 @ 40), (N/A, 20), (N/A)
(5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
(5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
(5735 - 5835 @ 80), (N/A, 30), (N/A)
(57240 - 59400 @ 2160), (N/A, 28), (N/A)
(59400 - 63720 @ 2160), (N/A, 44), (N/A)
(63720 - 65880 @ 2160), (N/A, 28), (N/A)

It stuck on CN for some reason and changing the global country form 98 to something else seems impossible ( tried using iw reg set but still doesn't work at all)

root@OpenWrt:~# iw list
Wiphy phy1
max # scan SSIDs: 4
max scan IEs length: 2242 bytes
max # sched scan SSIDs: 0
max # match sets: 0
max # scan plans: 1
max scan plan interval: -1
max scan plan iterations: 0
Retry short limit: 7
Retry long limit: 4
Coverage class: 0 (up to 0m)
Device supports AP-side u-APSD.
Device supports T-DLS.
Available Antennas: TX 0 RX 0
Supported interface modes:
* managed
* AP
* AP/VLAN
* monitor
* mesh point
Band 1:
Capabilities: 0x106f
RX LDPC
HT20/HT40
SM Power Save disabled
RX HT20 SGI
RX HT40 SGI
No RX STBC
Max AMSDU length: 3839 bytes
DSSS/CCK HT40
Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
Minimum RX AMPDU time spacing: 4 usec (0x05)
HT TX/RX MCS rate indexes supported: 0-23, 32
VHT Capabilities (0x33837930):
Max MPDU length: 3895
Supported Channel Width: neither 160 nor 80+80
RX LDPC
short GI (80 MHz)
SU Beamformer
SU Beamformee
RX antenna pattern consistency
TX antenna pattern consistency
VHT RX MCS set:
1 streams: MCS 0-9
2 streams: MCS 0-9
3 streams: MCS 0-9
4 streams: not supported
5 streams: not supported
6 streams: not supported
7 streams: not supported
8 streams: not supported
VHT RX highest supported: 0 Mbps
VHT TX MCS set:
1 streams: MCS 0-9
2 streams: MCS 0-9
3 streams: MCS 0-9
4 streams: not supported
5 streams: not supported
6 streams: not supported
7 streams: not supported
8 streams: not supported
VHT TX highest supported: 0 Mbps
Frequencies:
* 2412 MHz [1] (20.0 dBm)
* 2417 MHz [2] (20.0 dBm)
* 2422 MHz [3] (20.0 dBm)
* 2427 MHz [4] (20.0 dBm)
* 2432 MHz [5] (20.0 dBm)
* 2437 MHz [6] (20.0 dBm)
* 2442 MHz [7] (20.0 dBm)
* 2447 MHz [8] (20.0 dBm)
* 2452 MHz [9] (20.0 dBm)
* 2457 MHz [10] (20.0 dBm)
* 2462 MHz [11] (20.0 dBm)
* 2467 MHz [12] (20.0 dBm)
* 2472 MHz [13] (20.0 dBm)
* 2484 MHz [14] (disabled)
valid interface combinations:
* #{ AP } <= 16, #{ mesh point } <= 1, #{ managed } <= 1,
total <= 16, #channels <= 1, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz, 160 MHz }

    HT Capability overrides:
             * MCS: ff ff ff ff ff ff ff ff ff ff
             * maximum A-MSDU length
             * supported channel width
             * short GI for 40 MHz
             * max A-MPDU length exponent
             * min MPDU start spacing

Wiphy phy0
max # scan SSIDs: 4
max scan IEs length: 2247 bytes
max # sched scan SSIDs: 0
max # match sets: 0
max # scan plans: 1
max scan plan interval: -1
max scan plan iterations: 0
Retry short limit: 7
Retry long limit: 4
Coverage class: 0 (up to 0m)
Device supports AP-side u-APSD.
Device supports T-DLS.
Available Antennas: TX 0 RX 0
Supported interface modes:
* managed
* AP
* AP/VLAN
* monitor
* mesh point
Band 2:
Capabilities: 0x106f
RX LDPC
HT20/HT40
SM Power Save disabled
RX HT20 SGI
RX HT40 SGI
No RX STBC
Max AMSDU length: 3839 bytes
DSSS/CCK HT40
Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
Minimum RX AMPDU time spacing: 4 usec (0x05)
HT TX/RX MCS rate indexes supported: 0-23, 32
VHT Capabilities (0x33837930):
Max MPDU length: 3895
Supported Channel Width: neither 160 nor 80+80
RX LDPC
short GI (80 MHz)
SU Beamformer
SU Beamformee
RX antenna pattern consistency
TX antenna pattern consistency
VHT RX MCS set:
1 streams: MCS 0-9
2 streams: MCS 0-9
3 streams: MCS 0-9
4 streams: not supported
5 streams: not supported
6 streams: not supported
7 streams: not supported
8 streams: not supported
VHT RX highest supported: 0 Mbps
VHT TX MCS set:
1 streams: MCS 0-9
2 streams: MCS 0-9
3 streams: MCS 0-9
4 streams: not supported
5 streams: not supported
6 streams: not supported
7 streams: not supported
8 streams: not supported
VHT TX highest supported: 0 Mbps
Frequencies:
* 5180 MHz [36] (23.0 dBm)
* 5200 MHz [40] (23.0 dBm)
* 5220 MHz [44] (23.0 dBm)
* 5240 MHz [48] (23.0 dBm)
* 5260 MHz [52] (23.0 dBm) (radar detection)
* 5280 MHz [56] (23.0 dBm) (radar detection)
* 5300 MHz [60] (23.0 dBm) (radar detection)
* 5320 MHz [64] (23.0 dBm) (radar detection)
* 5500 MHz [100] (disabled)
* 5520 MHz [104] (disabled)
* 5540 MHz [108] (disabled)
* 5560 MHz [112] (disabled)
* 5580 MHz [116] (disabled)
* 5600 MHz [120] (disabled)
* 5620 MHz [124] (disabled)
* 5640 MHz [128] (disabled)
* 5660 MHz [132] (disabled)
* 5680 MHz [136] (disabled)
* 5700 MHz [140] (disabled)
* 5720 MHz [144] (disabled)
* 5745 MHz [149] (30.0 dBm)
* 5765 MHz [153] (30.0 dBm)
* 5785 MHz [157] (30.0 dBm)
* 5805 MHz [161] (30.0 dBm)
valid interface combinations:
* #{ AP } <= 16, #{ mesh point } <= 1, #{ managed } <= 1,
total <= 16, #channels <= 1, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz, 160 MHz }

    HT Capability overrides:
             * MCS: ff ff ff ff ff ff ff ff ff ff
             * maximum A-MSDU length
             * supported channel width
             * short GI for 40 MHz
             * max A-MPDU length exponent
             * min MPDU start spacing

and this is part of the system log

Thu Jan  9 06:00:48 2020 daemon.notice hostapd: wlan0: interface state DFS->DISABLED
Thu Jan  9 06:00:48 2020 daemon.notice hostapd: wlan0: AP-DISABLED
Thu Jan  9 06:00:48 2020 daemon.notice hostapd: wlan0: interface state DISABLED->DISABLED
Thu Jan  9 06:00:48 2020 daemon.notice hostapd: wlan0: AP-DISABLED
Thu Jan  9 06:00:48 2020 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING

VHT20 is not valid for 2.4ghz, change that to HT20.
Set the 2.4ghz channel to 1 and the 5ghz channel to 36 and see if both start working.

Thanks for the reply , just changed the settings

config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11a'
option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
option htmode 'VHT80'
option country 'AU'
option txpower '23'
option legacy_rates '0'
option channel '44'

config wifi-device 'radio1'
option type 'mac80211'
option hwmode '11g'
option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
option htmode 'HT40'
option country 'AU'
option legacy_rates '0'
option channel '1'

config wifi-iface
option device 'radio0'
option mode 'ap'
option network 'lan'
option wmm '0'
option encryption 'psk2'
option key 'something'
option ssid 'something'

config wifi-iface
option device 'radio1'
option mode 'ap'
option ssid 'something'
option wmm '0'
option encryption 'psk2'
option key 'something'
option network 'lan'

now both the 5GHz and 2.4Ghz channel are stuck on 54Mbps

Because you've disabled wmm for both. Its required for the higher rates if I recall correctly.

1 Like

just solved every thing by enabling WMM back , now all we have to do is to solve the region regulation problem

Which you can't, but you can patch the driver to stop clobbering the kernel every time you change it.

These devices tend to be hard coded to a region (although I haven't seen that on a 1900acs before... maybe a v2). The 1900acs is sold is Australia, did you buy elsewhere and get something region locked for outside?

I didn't get the Wrt1900acs v2 in AU , it's from somewhere else.
but now my notebook have around 480 Mbps Rx but weridly a 48Mbps Tx.
Also the 2.4Ghz channel have a max Rx rate of 144 Mbps only , maybe it's because my devices ?

saw this post WRT1900ACS v2 how to update mwlwifi driver and someone did hack a mwlwifi driver patch , but I don't know if it will work on the leastest 18.06.5 firmware which I'm using .

image
As you can see , I'm running the 2.4GHz on VHT20 ( which the WRT1900ACS can do )
the note 10 is on 2.4GHz N and it only have 144Mbps (tried using the notebook and HT20 , HT40 , same result)
The RX rate is low but it shouldn't be a problem at all as I seldom upload large files.
It can bump up to 4xx Mbps sometimes and soon it drops but as I've said this won't be a big problem.


Sorry I've used up the new member reply limit so I'll be replying at here instead.
Seems it doesn't have DTS (but doesn't the AU use TPC ?)

driver name: mwlwifi
chip type: 88W8864
hw version: 7
driver version: 10.3.8.0-20181114
firmware version: 0x0702091a
power table loaded from dts: no
firmware region code: 0x90
mac address: 00:25:9c:14:4b:fb
2g: disable
5g: enable
antenna: 4 4
irq number: 48
ap macid support: 0000ffff
sta macid support: 00010000
macid used: 00000001
radio: enable
iobase0: e0e80000
iobase1: e1000000
tx limit: 768
rx limit: 64
qe trigger number: 129456

The main point is I want to use the 100 channel as others are crowded and the only few empty channels are near 100 and my router can't get to it .

Oh alright , Thanks so much for your help , I might get the driver done later on.

It won't change the power limits though, it will just stop it getting upset when you do change it. The patch just ignores the request (my understanding).

Just to check, what does
cat /sys/kernel/debug/ieee80211/phy0/mwlwifi/info show?

If it shows Loaded from DTS true, your easiest and best method is just to patch the DTS to swap the powertables for CN and AU, and then don't change the country code at all.
You're fortunate that both are defined for this device.
https://git.openwrt.org/?p=openwrt/openwrt.git;a=blob;f=target/linux/mvebu/patches-4.14/002-add_powertables.patch;h=c5a211dd40428996e2f50338338c279f4012038e;hb=refs/heads/openwrt-19.07

The patched mwlwifi might work for you then, but I'm not entirely certain. Enquire in that thread (Which will also assist your new user status). The original 2 questions in the topic are already resolved anyway.

  1. Fixing the Wi-Fi settings got it online
  2. No you can't change the region on this device (without custom drivers or other such hacks)

The easiest advice is to just walk to a jb hifi and buy the right thing :wink:

That's normal behavior.

Not advised.

FYI...Channel 100 is not authorized in China. While true that you may not be in China; your router thinks it is.