Can't flash UI to Netgear DM200 modem

I installed v 18.06.0 on a Netgear DM200 it I could not get it to connect to my ISP (Internode Australia). With the original firmware it was OK.
Then I flashed "openwrt-lantiq-xrx200-netgear_dm200-squashfs-sysupgrade.bin" but there is no UI. I tried to install LUCI, but the modem could not connect to the internet. At the moment it is connected to an ADSL modem/router. I can ping the router from the modem, but that is it.
Could someone tell me how to install LUCI or re-flash the stable release via ssh?
Thanks kindly!

This image did not include luci?

It should include luci. Thats the official stable image. They are with luci integrated.

You can scp over ssh the image and run sysupgrade if you like to flash/install it once again or to update to any other image.

I cannot access the modem via in a web browser...

I managed to copy the image to the modem, however when I tried to run the 'sysupgrade' command it was not found. WTFrag???

You should not access in a webbrowser. When you say that there is no luci, then this is normal.

Here about scp in combination with sysupgrade:

I managed to copy the image to the modem, however when I tried to run the 'sysupgrade' command all I got is this error message
"sysupgrade: command not found"

you have already openwrt running on it? Can you show the output of "uname -a".

Linux OpenWrt 4.14.62 #0 SMP Fri Aug 10 16:43:23 2018 mips GNU/Linux

What is this image you have flashed on? It writes " Fri Aug 10 16:43:23 2018". So the kernel is been build then.

But the 18.06 image i wrote about is been build end of july 2018:

You wrote in your first post "I installed v 18.06.0 ". But that does not look like that. You have installed something else but probably not 18.06.0.
The file you flashed on your device is named netgear_dm200-squashfs-factory.img or netgear_dm200-squashfs-sysupgrade.bin and have the sha256sum 476db4aa7ffe153cef3c7c0526fffdb0acefa19b52eab8d446ea717cd8bfb4c4 or 628196f52a816a053fedc717671e70179c771ea496018377d3877a0092d85cb8 ? If not, then you have flashed something else.

SHA256: 30d241e0c294d61d500304c27f8d0e45b2104f229e0c194c0270edd09b8698ef

Yes, thats the confirmation that you have not installed the official released image that normally include sysupgrade and luci.
Here are the official images and their sha256 sums:

I also copied out the two possible sha256 sums for your device in my last post.

Snapshot builds do not have a release number in the file name. That is what you flashed. sysupgrade should still be present in those though.

After you scp the new firmware to the router, then you would ssh log in to the router, cd to /tmp on the router (where scp placed a copy of the firmware image), and run sysupgrade. You may have tried to run sysupgrade as a command on your PC instead of on the router. That will not work.

The error message when you try to run a command on the router that is not present is something like:

-ash: dir: not found

It is not "Command not found"

Well I managed to use sysupgrade to flash openwrt-18.06.0-lantiq-xrx200-netgear_dm200-squashfs-factory.img and it looked like it finished successfully:

Commencing upgrade. Closing all shell sessions.
Connection to closed by remote host.
Connection to closed.

However now the power LED is flashing and I cannot access the modem via ssh

Wait, don't touch it for at least 15 minutes. Then if it still does not respond, cut the power and reboot.

be patient, it needs time to write image to flash

Ouch, I restarted it, believing it finished the flashing. I guess it is now bricked...

If ever software needed a "Please Wait Processing" message this does.

You should always wait at least those 15minutes. Its a known safe time to wait after each flash.

And even without that: Why did you "restart" it? A sysupgrade always restarts the device itself when its done. Its same workflow on all routers i know. Indipendent if its openwrt, dd-wrt, netgear, tp-link, avm fritzbox, ...
You give them a file and press update and wait until they reboot and are available again with the webbrowser. You never cut off the power in such cases. Just when after 15 or even 30 minutes the device is still not accessable, then you can try to cut off the power.

The DM200 devicepage is still missing installation instructions.
This would be an opportunity to also add a clear statement like "Wait at least15min for the flashing process to finish."

Is anybody up for adding installation instructions to the devicepage?

Even with the official/stable/whatever 18.06.0, which I successfully flashed, it could not connect to my ISP, so there is some issue with the firmware for this modem...
Case close, modem bricked, modem binned.
Thanks for taking time to respond!

Have a look at some other netgear router unbrick instructions. It is usually somthing simple like '

  1. power off device
  2. hold reset button down
  3. power on device and keep holding reset button for about 20-30 seconds until leds flash second time
  4. use tftp to upload image to device ( need to use manual static IP on PC)
  5. wait 15 minutes until it reboots.

I cant test procedure because i don't have that device but has worked with other netgear devices
Scroll down to Recovery flash in failsafe mode for a sample procedure if you cant find something more specific to try