Can't flash img to SD Card

Hey, I can't flash.img file with multiple .img files inside to a micro SD Card.
My SD Card creates multiple partitions after flashing the .img. I found out that this image (friendlywrt) has mutiple .img files inside its main, like 0.boot.img 1.kernel.img.
I don't get it, how can I flash that?

Edit: I attached a picture, like I said instead of a successful flash and an image I get 8 new partitions and a broken SD card.

By the looks of it, you just did.

Yeah, blame the SD card.

According to their wiki, you should use dd.

An OpenWrt image contains a partition table (aka disk label). Copying the binary image literally block by block to the card will replicate the complete system with multiple partitions and filesystems within those partitions. This means that when using Linux and dd you would make the output file the root of the card (usually /dev/sdX, where X is usually 'b') rather than any existing partition on the card (e.g. sdb1). Any existing partitions on the card will be clobbered by the writing of the new partition table.

OpenWrt images are also compressed with gzip. It is essential to unzip before writing or pipe gzip to dd:
gzip -cd IMAGEFILE.bin.gz | dd of=/dev/sdX bs=4M

I tried with dd on my mac and I still can't boot from it. But I have no problems flashing OpenWrt which also contains two .img files. I begin to think that the friendlywrt build I try to flash is faulty...


I tried that today but I still can't boot from it. No problems with OpenWrt though

If openwrt boots just fine, you should really ask the friendly people at FriendlyWRT.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.