Can't flash Archer A7

Hi, guys! I connected to the device’s technology console and see next output when trying to upgrade to openwrt:

1.0.14 Build 20200220 rel.33197
upgrade firmware...
md5 verify ok!
[Error]sysmgr_proinfo_buildStruct():  605 @ unknown id(device_name), skip it.
[Error]sysmgr_proinfo_buildStruct():  605 @ unknown id(hw_id), skip it.
[Error]sysmgr_proinfo_buildStruct():  605 @ unknown id(oem_id), skip it.
[Error]sysmgr_proinfo_buildStruct():  605 @ unknown id(country), skip it.
[Error]sysmgr_proinfo_buildStruct():  605 @ unknown id(hw_ver), skip it.
      vendorName : TP-Link
       vendorUrl :
     productName : Archer A7
 productLanguage : EU
       productId : 00070005
      productVer : ff050000
       specialId : 52550000
           hwlId :
           oemId :
[Error]sysmgr_cfg_checkSupportList():  909 @ 45550000 NOT Match.
[Error]sysmgr_cfg_checkSupportList():  909 @ 55530000 NOT Match.
[Error]sysmgr_cfg_checkSupportList():  909 @ 43410000 NOT Match.
[Error]sysmgr_cfg_checkSupportList():  909 @ 4A500000 NOT Match.
[Error]sysmgr_cfg_checkSupportList():  909 @ 54570000 NOT Match.
Firmwave not supports, check failed.
[NM_Error](nm_checkUpdateContent) 01075: hardware version not support
[NM_Error](nm_buildUpgradeStruct) 01188: checkUpdateContent failed.

check firmware error!
[NM_Error](nvrammanager_verifyFirmware) 00476: upgradeFirmware failed

This happens both when trying to update via the web-interface, and when trying through tftp...
Can we expect any solutions to this problem?
PS: I have a full dump of the FlashROM

Have you guys tried that solution, seems to work for a bunch of A7 v5 users:

Then from Snapshot you could move to another kind of build if desired, using the upgrade image.

Also, reverting to an old factory image before switching to OpenWrt can help sometimes. Try to flash the oldest factory version found on the TP-Link Website. Archived version of the Website for Archer A7 v5:

Direct download link to the oldest firmware Archer A7 v5 found:

Thanks! I will try your variant of solution tomorrow :wink:

Unfortunately, I have the same result ... :roll_eyes: Device doesn't want to update firmware.

Recently acquired an A7 v5 and wanted to replace an old wrt54gl that I was using as a wireless bridge. I ran into the same issues listed in this thread, but did end up getting it loaded in the long run. The steps that resulted in my success were as follows:

  1. I did a 'OEM GUI' load using the 19.07.3 snapshot (specifically 'openwrt-ath79-generic-tplink_archer-a7-v5-squashfs-factory.bin'). The GUI showed normal progress bar during load, but after it finished and rebooted I was unable to get any DHCP address while having my laptop directly connected to LAN ports.

  2. Did a factory reset (this fixed the issue with being able to obtain a DHCP address)

  3. Since 'snapshot image' doesn't have LUCI, I SCP'd a copy of 'sysupgrade image' to /tmp on the A7. Specifically this image ('openwrt-19.07.3-ath79-generic-tplink_archer-a7-v5-squashfs-sysupgrade.bin'). I then just manually upgraded via cli 'sysupgrade -v /path/to/image'

  4. Everything seemed to be working great, and was able to configure device via LUCI, but I noticed config did not persist after reboot. Found an article on this buried in another thread, that discusses 'Failsafe Mode', and possible corrupt 'overlayfs'. A 'df-h' showed 'overlayfs:/overlay' with only around 20k free. Seemed pretty low, so I did a hard factory reset / re partition via cli 'umount /overlay && jffs2reset && reboot now'. et voila, I now have 10.5M partition, and plenty of space to save config. Config now persists after reboots, and I have a proper running A7 on 19.07.3.

Hope this helps anybody else that may be struggling to get openwrt on their A7.

Best regards.....

@netskillz , I am also running an A7 v5. it has the firmware: 1.0.15 Build 20200628 rel.63501 and I cannot use the GUI to upgrade to openwrt or downgrade to an older version of the tp-link firmware. I always get an 'Invalid file type.' message.

I recently bought one of these and use it as a repeater.Flashed it to the latest available TP-Link firmware from their website then flashed it with 19.07.3 factory. I think I renamed the file to simpy firmware.bin it flashed first time and no issues since. This was all flashed from the TP-Link gui.

Even with the openwrt 'snapshot install' image?

I kept getting the same error about 'Invalid file type' when I tried to use the regular install method, even if I modified the filename to something shorter..

The snapshot doesn't have a GUI though, so will require you to login via SSH, and manually upgrade again using the 'sysupgrade' image to get LUCI. (Or you could manually install LUCI on the snapshot image)

Yes that is what I did once I had the base openwrt installed I ssh'ed into the box updated the packages opkg update and then installed luci.

On reboot all was good. Now running the awesome material theme. I think I also installed some additional luci addons like full admin etc.

I definitely had to change the name to firmware.bin I remember. The whole process took less than 10 minutes and was a lot simpler than I expected.


Hi, I'd just like to report that flashing the latest image through the TP-Link web admin portal seems to have worked perfectly. No errors like "Incorrect Image." However, using a renamed file --- ArcherC7v5_tp_recovery.bin --- as is recommended on the wiki did not work either through tftp or the web portal.

OpenWRT v19.07.4
(Using MacOS as the tftp server.)

That means you have flashed openwrt-19.07.4-ath79-generic-tplink_archer-a7-v5-squashfs-factory.bin via the TP-Link GUI without renaming the OpenWrt image file?

Do you remember which version of the TP-Link firmware you had on your A7 before flashing OpenWrt?

Hi everyone,

Wanted to know if I can flash on Archer A7 (EU) as well? Or does it only work for US version?

Hello i just flashed TL-AC1750 Archer A7 V5 (EU) via TP-Link GUI.
When i brought i had TP-Link firmware wersion 1.0.11, then i upgraded to 1.0.15 Build 20200721 rel.40773(4555). From this point i flashed openwrt-19.07.4-ath79-generic-tplink_archer-a7-v5-squashfs-factory.bin via web panel without changing any names.
From Luci web panel almost everything works fine. There are known bugs like i can't update WAN mac address through Luci, but it can be done through ssh.
DHCP static bindings on LAN has to be choosen from active hosts.


I can confirm that TL-AC1750 Archer A7 V5 can be flashed from TP-Link GUI
I have US version of the device.

Archer A7 v5 started with 1.0.11 Build 20190810 rel.50990. I upgraded it to latest TP-Link firmware that was available. In my case it was 1.0.15 Build 20200721 rel.40773.

After that I flashed it with openwrt-19.07.4-ath79-generic-tplink_archer-a7-v5-squashfs-factory.bin
File was not renamed.
Worked great.

I have no success flashing via tp-link manual update, getting an error about incorrect file. Firmware installed now is 1.0.15 Build 20200721 rel.40773(5255)
I flashed back to 1.0.11 Build 20190810 rel.50990(5255) firmware and I have the same result about incorrect file

Can confirm this process worked for me just like virion said.

What exact steps did you take benzodm?

That special id seems to be missing:

Which version of the A7 v5 do you have, EU, US, RU,...?

Version is A7 v5 RU

Then you need a header including special_ID 52550000 which is ASCII for "RU".

I think you can change this just by editing the "factory" binary with a hex editor, replace one of the other country codes.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.