Can't find latest 18.06 firmware for TL-WDR3600

Hi,
I have a TL-WDR3600 with OpenWrt 18.06.1. I wanted to upgrade it to the latest 18.06 release, 18.06.9... but I can't find the correct image. I can find the latest 22, but not 18.

I tried deconstructing the url for 22:

https://downloads.openwrt.org/releases/22.03.3/targets/ath79/generic/openwrt-22.03.3-ath79-generic-tplink_tl-wdr3600-v1-squashfs-sysupgrade.bin

But 18.06 does not have a ath79 folder. Tried also searching for tplink_tl-wdr3600-v1 and 18.06 - nada :wink: Is there some old versions search?

Can you help me finding the correct 18.06.xx firmware for this device?

Thanks,
Samo

Devices with these chipsets used to be in the ar71xx target. They migrated to ath79 starting in OpenWrt 19.07

But why do you want to use an old release such as 18.06? It has been EOL for many years, contains many security vulnerabilities, and is entirely unsupported.

Your device supports 22.03... is there a reason you don't want to (or can't) use it?

3 Likes

Old versions are stored in archive.openwrt.org. 18.06 can be found by going to the downloads.openwrt.org index page and following the links. But you should not use it.

3 Likes

I saw it support 22.03 - but there's a warning regarding the size of the flash/ram. This hardware fits the requirements but just barely.

The other reason is that I didn't want to reconfigure the router because of upgrading major versions.

I guess I'll find the latest 18, create a backup and give a try with 22.03.

Thanks.

The Last 18.06 can be found here:

Though I'd have a look at 19.07.10 as it's the last ar71xx release for the WDR3600

2 Likes