Can't figure out WiFi

I've installed OpenWRT on Proxmox VM. LAN works fine, everything works as expected. But WiFi just doesn't. I have no idea what's wrong. It's using the AX200.

The AP shows up and I can connect to it, but that's about it. Nothing is going through, not DHCP not even ping. I now tried making a bridge but even that didn't help. Before I tried with the bridge I just set the network in the Access Point to "lan"

network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd62:a1a9:6a23::/48'

config interface 'wan'
	option device 'eth1'
	option proto 'dhcp'

config interface 'lan'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.0.19'
    option netmask '255.255.255.0'
    list ifname 'eth0'
    list ifname 'wifinet0'  # Add wifinet0 to bridge the wireless interface
    list dns '192.168.0.1'

wireless config

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:10.0'
	option country 'SI'
	option cell_density '0'
	option htmode 'HT20'
	option band '2g'
	option channel '6'

config wifi-iface 'wifinet0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'psk2'
	option key 'bremza87'
	option network 'lan'

firewall(ignore the 3.3.3.3. I'm setting up a small OpenWrt device for my Tesla, and the car blocks bogons)

config defaults
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	list network 'lan'

config zone
	option name 'wan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option masq '1'
	option mtu_fix '1'
	list network 'wan'
	list network 'wan6'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config forwarding
	option dest 'lan'

config forwarding
	option src 'lan'

config redirect
	option dest 'lan'
	option target 'DNAT'
	option name 'Test'
	option family 'ipv4'
	list proto 'all'
	option src 'lan'
	option src_dip '3.3.3.3'
	option dest_ip '192.168.0.21'

Remove this line. It is added from g/wireless

1 Like

That was super fast. And annoyingly simple. I swear chatGPT(who recommended the config you fixed) is making me (and probably someone else) lazy and stupid. :stuck_out_tongue:

1 Like

As per brada4 beating me to it.....

Shouldn't need to add the wireless adapter to the bridge.
Having the config under wifi-iface as network 'lan' should be fine?
It then gets added to bridge when wireless starts.

Why AX200? Assuming intel client card running in AP mode? I don't have experience with newer intel cards in AP mode.....

It's the minisforum S100, works on 20v usbc, so I can power it in the car and run some VMs on it. Only thing I have to work with right now. Waiting for a RT3572 dongle.

1 Like

Stay out of it, it only messes stuff up. Worst it throws weird constants across the board, yours is something new though :wink:

1 Like

If you can get mt76 card, though full separate (dumb) AP may turn out cheaper.

1 Like

You mean compared to the whole setup?

It's a bit complicated, I'm running KASM on one of the VMs, so I need the Minisforum S100 for that. I initially had the car connect directly to a home server but as KASM is live transmit I had issues when the car was moving. So I decided to put the KASM server in the car and everything else it does (youtube/plex) will buffer on it.

Just for clarity, the passenger uses it, not the driver.

I'm not familiar with mt76, but the dongle I found is like 20€, was just difficult to find. And performance is not a big requirement, anything above 10-15 Mbps will be enough :slight_smile:

EDIT: also, just for more context. I initially wanted to use KASM for a better browser experience, tabs, auto login, history management and so on. But then I quickly realized video works while driving. So I just had to experiment. Basically I have a Proxmox server in the car, running at 9w of a 20v cigarette plug charger.

welll...

It says both ax200/ax201. If it's ax201 replacing the built in card becomes no go? CNVio2..... not pcie =(

But yeah i think the reason why mt76 is suggested is due to software support and better AP mode options?

Roughly it supports most features, ath 9 10 are ok too.

1 Like

It's the AX200.
Works great now though, everything as it's supposed to be :slight_smile:

Phone tethering through cable and then through Wi-Fi access for the car. In between I can modify the traffic as I see fit with OpenWRT.

Thanks for the help :smiley:

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.