Cant create an 802.11s mesh

I had a mesh working in adhoc mode, but I want to configure and set up 802.11s mesh.

Wireless settings

config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
option country 'IE'
list ht_capab 'LDPC'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'TX-STBC'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option device 'radio0'
option mode 'ap'
option ssid 'TestNET'
option encryption 'none'
option disabled '0'
option network 'lan'
option hwmode '11n'
option txpower '10'

config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option encryption 'none'
option ssid 'TestNET'

config wifi-iface 'mesh0'
option device 'radio0'
option ifname 'mesh0'
option network 'nwi_mesh0'
option mode 'mesh'
option mesh_fwding '0'
option encryption 'none'
option ssid 'mesh'
option bssid '02:CA:FE:CA:CA:40'

Networking Settings

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd67:09fe:151f::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth0'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'nwi_mesh0'
option ifname 'mesh0'
option proto 'batadv'
option mesh 'bat0'

option routing_algo 'BATMAN_V'

    option mtu '2304'

valid interface combinations:
* #{ managed } <= 2048, #{ AP, mesh point } <= 8, #{ P2P-client, P2P-GO } <= 1, #{ IBSS } <= 1,
total <= 2048, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz }
The version of openwrt installed is 18.06.2
Wpa-supplicant is the only wpa installed.
The bat0 interface is present in adhoc mode but once I change it to mesh mode in wireless settings, the interface is no longer visible using the command ip link.
Cheers thanks any help appreciated.

You need wpad-mesh for 801.11s

(wpad-full does not work)

1 Like

Thanks for the quick response

Hmmm, no encryption, correct?

Which wireless hardware?

Do not set a bssid on an 802.11s interface. It is based on the mesh_id (a required setting that you don't have) and the channel matching. Mesh_id is an arbitrary string with the same rules as ssid. Channel numbers must be explicitly set and the same on all the nodes. Your global radio config is the very old syntax which may not work on newer versions. On a 2 GHz n radio, use hwmode 11g along with htmode HT20. There is no need for ht_capab settings and hwmode 11n is not valid at all. You have tried to define an AP in the wifi-device section, remove that. It's defined in a separate wifi-iface section.

2 Likes

almost everything was described here: Trouble getting batman-adv working

I’m using a laguana gateworks board its no longer supported, to install any new packages I have to build a new image using make config. Therefore before I take on building the new image I will end up with will be the version of openwrt installed is 18.06.2 with the propper packages such as wpad-mesh installed,
Do you think that this will work,
Read through the other wiki and still confused as to what version of openwrt support 802.11s.
The drivers I have are doodle lab drivers in their specks the show that the support mesh and their running on ath9k software.
Any advice appreciate.

The configuration changed on master at the beginning of 2019. batman-adv has been supported for several years now, with the version in the package changing over time, at least as far back as

commit 48f38ba
Author: Travis Kemen <thepeople@openwrt.org>
Date:   Sat Mar 17 03:59:59 2007 +0000

    add B.A.T.M.A.N. from #1448


You're sort of on your own with those to get support from the vendor if there are problems in the driver, especially on an older release of OpenWrt. It wouldn't be the first time that a driver claimed to support a feature and didn't.

Trying to see if my mesh is up and working in adhoc mode.
Below are the results from ifconfig -a and brctl show, I can log on to either of the 2 nodes and get internet. But bat0 is not connected to br-lan. does this mean that the mesh is not working.

image

image

If batctl shows neighbors and originators, the mesh is up and batman is routing. Past that, it is what you want to do with the bat0 network. Just like having eth0 connected, it can’t read your mind as to how you want to use it.

Cheers thanks for the quick response