Can't connect with default root login/pass on Kimax BS U25AWF (password invalid)

Ok I'll give a another try.
From the openwrt guide:
Watch for a boot message on the serial console and press a key (β€œf”) on the serial keyboard. This requires that you have attached a serial cable to the device. The message shown in the console is β€œ Press the [f] key and hit [enter] to enter failsafe mode”

But I will try again with different buttons/timings/leds/etc...

@anon69880279 maybe has an idea what can be the root password?

1 Like

Thanks trendy ! I did not know how to contact him !

no password after firstboot ( with serial console )

openwrt web default password is empty

Thank you for the confirmation @anon69880279 !

@Romain before going into soldering the serial port, maybe you could try to re-upload the image (or another one)? Usually you need to press the reset button while power is off, keep pressing and power on, then wait until leds start blinking to release the button. Then router will have an http page at default address where you can upload the image.

Hi all,

I did some new test. With wireshark I can see the "Please press button now to enter failsafe...". If I press the power button, it powers off. If I press reset button, or nothing, I got ping from response from for about 10seconds.
During that time, no connection possible with telnet on
With SSH, I got a connection refused.

After these 10seconds, it boots normally with Luci asking for password. But I can't login...

It seems I can't trigger the failsafe button.

@trendy I can't manage to boot in the mode you described. It boots normally.

I noticed that once booted, or while booting, if I press briefly the power button, the blue LED (HDD) stays lit, with power LED (Orange). But I got no response with ping/http/ssh.

Have I to try soldering a keyboard ? Like this
But I don't know to what wires I should connect these 3 ones (a ps/2 keyboard ? oO)

Also, is there a way with the TFTP firmware upload thing ? I did the tftp command in multiple state of booting, or while the responded to pings, with no success...

That was my plan b :cry:

Bummer. I remember I enabled the tftpd on routers with this sequence back in the days. Looks like it is not used much anymore.

I have managed to connect to serial without soldering. If the pins are thick enough to fit the holes, then you are lucky. Or crocodile cables.
Then you'll need a serial ttl cable (usually has USB on one end and 4-8 cable pins on the other) and some terminal emulator, like Putty, Minicom, SecureCRT.

1 Like

@trendy, about the TFTP thing, I think the box was not waiting for any file... In what mode should I launch the TFTP command ? after what buttons combo ?

If I am not mistaken, cause it's been ten years since I last did that, I was pressing the reset button, powered on, waited for 15 seconds or so, the LEDs were blinking like Christmas tree, and ping was responding. At that point I released the reset button and pushed the image with TFTP to the router.

I just bought this adapter, I will receive it on monday. I'm too curious about communicating with uart devices :slight_smile:. I will try to pass some pins through the pads without soldering, as you said. Otherwise I got some soldering skills. Pads are small, but I got hardware for such things...

From there I'll be able to get hand back on the Kimax firmware, and the other UART stuff I would get in the future. Thanks for all the advices. I will come back later to tell you how it has worked.

TEst with your old password or default for chinese firmware 12345678

@anon69880279, not better with 12345678, so I tried all the collection: 0123456789, 1234567890, 123456789...

I should receive the UART USB adapter today ! :slight_smile:

I will try again with the same image, if its not better, I will (re)do a WRT firmware with the U25AWF patches and all that was used to make your image... I think there is the needed infos in the old forum's posts...

Hey wait a minute, if I have control with SSH, I could make new passwords and accounts :smiley:

Yes there is password recovery procedure when you connect with console.

1 Like

Hi all,

I'm proud to celebrate my first day with OpenWRT working :slight_smile:
I soldered some pins on the rx/tx/gnd pads, plugged the pins in that UART/USB adapter thing, launched that "tera term" other thing, preyed the gods (all of them), and hey ! I got a terminal working !!!

After beeing able to talk with that Kimax box, I could not manage to change the password of the Kimax system, only the password from a "recovery system" ? (I got a /etc/shadow and a /rom/etc/shadow in read-only, and they was different). My account also was "admin" instead of "root". Though the passwd command worked, I still was not able to log with LuCi or SSH (even with mount_root command)...

After doing a "umount /overlay && firstboot && reboot" a couple of times, trying to hit "f" then "enter" when the box was telling me to do so, and nearly thought the box was dead cause it was booting in loops, I finally managed to land in a shell with a "root" account. I changed the password, and allelujah, I could log into LuCi !!!

So then, I decided to have a meal. LoL
Right now I'm playing with openWRT and trying to make everything work (I am trying to make exfat work ^^, but that's a different story... from what I seen, I must compile it, but I'm still searching what package to compile. Must it be a kmod ? whatever, I will potentially ask in an other thread if I can't find by myself)

Thank you all for helping me, so now I can play with OpenWRT, and even talk to some electronic devices in serial mode with an UART cable !!! I had a lot of fun :smiley:
And thanks to @anon69880279 for having shared his firmware. Even if it may have a login issue... but maybe I am the issue :stuck_out_tongue_winking_eye:


Hostname Kimax
Model Kimax U-25AWF
Firmware Version OpenWrt SNAPSHOT r6567-db893ec7f0 / LuCI Master (git-18.088.49307-90ed423)
Kernel Version 4.9.87
Local Time Thu Jan 17 00:15:19 2019
Uptime 0h 34m 18s
Load Average 0.54, 0.15, 0.05


Total Available 93748 kB / 125588 kB (74%)
Free 89104 kB / 125588 kB (70%)
Buffered 4644 kB / 125588 kB (3%)

PS: for those having the same problem, I did not found the cause, but a solution: get an UART/USB adapter connected to the board, and change the password with passwd (I had to try different booting options to get a terminal working for my actual openWRT and not a "recovery mode environment").

1 Like

@anon69880279, can you tell me if that firmware is very specific for U25AWF ? I mean, if I want to add sdfat, I have to recompile, so I will have to do all that you mentioned in your old post ?

git clone

After :
scripts/feeds uninstall freeswitch
git pull
scripts/feeds update -a
scripts/feeds install -a
make menuconfig

Quick Image Builder : … ild-images


Patch for BS-U25AWF … era:u25awf

Edit the 7 files modified by daniel kucera
remove tmp folder
make menuconfig -> tag BS-U25AWF (16 MB )
make -j4


I think you have not waited long enough for the update to be complete (it's quite long)

for compilation, yes, it should work

is there a simpler way to have sdfat working ? Maybe I can edit your firmware instead of reinstalling all the patches...

You can simply add options:

opkg update
opkg install xxyyzz --force-dΓ©pends

1 Like

Thx @anon69880279 --force-depends works for some packages.
For sdfat, I could not get it working (I think I have to recompile with the option to enable patented things, maybe I will try this later when I will know more about openwrt/lede systems).
For now I just reformated using ext4 FS.

By the way, I had to do a factory reset of your image, and after that I DID got the "root has no password" message, and was able to log without root password ! (And I could change password through the Luci interface).

Everything works quite well, I got lan, samba over lan, my SSD can be used through samba... I have wifi working and can even use the hdd as a router to get internet if a network cable is connected on it !

But I'm always trying to get more :slight_smile: since samba doesn't work well through wifi or when the Kimax HDD is connected on the same lan through cable and wlan, im trying to get a php based file browser (webdav is working, but I also want to be able to write and delete on the disk...). For having a decent web file browser working, I need PHP to work... But for now I get a " Bad Gateway The process did not produce any response" on every PHP file I attempt to use. I'm creating a new post for that...

Anyway your snapshot for Kimax seems to work quite well now ^^

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.