Can't connect to WiFi

Hi,
I'm trying to connect to my wireless network, but getting error messages on my phone/laptop that they can't connect to it. LAN interface works fine.
My LAN network is 192.168.1.x and I would like to have a separate DHCP for my wireless clients and issue IPs in range 172.14.1.x

I was following this guide but it still doesn't seem to work.

Below are my configs:

/etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd2d:31a8:fd1e::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan2'

config interface 'wan_eth'
	option proto 'dhcp'
	option device 'lan1'
	option metric '10'

config interface 'wan_lte'
	option proto 'qmi'
	option device '/dev/cdc-wdm0'
	option apn 'XXX'
	option pincode 'XXX'
	option auth 'none'
	option pdptype 'ipv4v6'
	option metric '20'

config interface 'lan'
	option proto 'static'
	option device 'br-lan'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'

config interface 'arlo'
	option proto 'static'
	option ipaddr '172.14.1.1'
	option netmask '255.255.255.0'
	option device 'phy0-ap0'

config device
	option name 'phy0-ap0'

/etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel 'auto'
	option band '2g'
	option cell_density '0'
	option country 'NO'
	option htmode 'HT20'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option ssid 'ARLO_BASE'
	option encryption 'none'
	option key '12345678'
	option wmm '0'
	option network 'arlo'

/etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option localservice '1'
	option ednspacket_max '1232'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'


config dhcp 'arlo'
	option interface 'arlo'
	option start '100'
	option limit '150'
	option leasetime '12h'

config dnsmasq 'Arlo'
	option rebind_protection '0'
	option localservice '0'
	list interface 'arlo'

/etc/config/firewall

config defaults
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	list network 'lan'
	list network 'arlo'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	list network 'wan_eth'
	list network 'wan_lte'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config redirect
	option dest 'lan'
	option target 'DNAT'
	option name 'HTTPS'
	list proto 'tcp'
	option src 'wan'
	option src_dport '443'
	option dest_ip '192.168.1.12'
	option dest_port '443'

config redirect
	option dest 'lan'
	option target 'DNAT'
	option name 'http'
	list proto 'tcp'
	option src 'wan'
	option src_dport '80'
	option dest_ip '192.168.1.12'
	option dest_port '80'

config zone
	option name 'arlo'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	list network 'arlo'

config forwarding
	option src 'arlo'
	option dest 'lan'

config forwarding
	option src 'lan'
	option dest 'arlo'

config forwarding
	option src 'arlo'
	option dest 'wan'

Hope someone can point me in the right direction

That guide applies when you want to connect your wireless router to another router using wifi. Looks like what you need is a separate wireless network; look for the guest network guide.

1 Like

Remove the key and try to connect to that AP. If you have to, enable security to get to it and then delete it. save/save and apply then go back to security disable security save/save and apply

Thank you for your replies, I'm not sure what solved this exactly, but after I removed the key and restarted the router, I was finally able to connect

That is great!!

Persistent phantom configurations have a tendency to break things.

1 Like

Please note that 172.14.1.x are ordinary IP addresses routable on the Internet. If you meant to use a private RFC1918 20-bit address, you should choose the range 172.16.0.x to 172.31.255.x.

1 Like

Thanks for info.
In this case, I'm trying to simulate Arlo base station (video surveillance) so I'm forced to use same IP addresses and configurations that base station had :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.