Can't connect to wifi

I'm using MT7688 (wizfi630s module).

I want to connect to my ap router with wifi and share connection to lan ports but can't connect to wifi...
Please teach me how to do something in next action!

openwrt version is 4.14.111

board has 1 wan port , 2 lan port, wizfi630s support 2.4Ghz wifi
one antenna https://www.mouser.kr/ProductDetail/WIZnet/W5I-BO-07?qs=b%252BXOOdUOuvZsX3%252B50akH%2FA%3D%3D

wan/wifi/run led is turned on

successful try:

  • wired wan, wired 1 lan

failed try:

  • no wired wan, wired 1 lan, wifi from iptime ap
  • iwinfo apcli0 scan
    • it works, read info around my spot.
  • iwinfo wlan0 scan
    • No such wireless device: wlan0
  • iw apcli0 scan
    • nl80211 not found.
  • openwrt web page (/cgi-bin/luci/admin/network/wireless)
    • scan button click of radio0
      • prints 'Starting wireless scan...' message and doesn't get result..

/etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd94:b81f:66ab::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option ipaddr '192.168.253.1'
option force_link '1'

config device 'lan_dev'
option name 'eth0.1'
option macaddr '00:08:dc:60:68:d9'

config interface 'wan'
option ifname 'eth0.2'
option proto 'dhcp'

config device 'wan_dev'
option name 'eth0.2'
option macaddr '00:08:dc:60:68:d8'

config interface 'wan6'
option ifname 'eth0.2'
option proto 'dhcpv6'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '3 4 6t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0 6t'

config interface 'wwan'
option device 'apcli0'
option proto 'dhcp'

/etc/config/wireless
config wifi-device 'radio0'
option type 'ralink'
option variant 'mt7628'
option country 'KR'
option channel 'auto'
option hwmode '11g'

config wifi-iface 'ap'
option ifname 'ra0'
option device 'radio0'
option mode 'ap'
option network 'lan'
option ssid 'WizFi630S_AP_6068D7'
option encryption 'none'
option disabled '0'

config wifi-iface 'sta'
option mode 'sta'
option network 'wwan'
option ifname 'apcli0'
option device 'radio0'
option key 'password'
option encryption 'psk2'
option ssid 'ipt_joseph_temp2'
option disabled '0'

there's no such openwrt version, please reach out to the vendor.

2 Likes

Most likely the kernel version used in Mediatek images 18.06-19.07, which are no longer supported.

Yes, snapshot is exact version..

As @frollic already said, this is not OpenWrt -- this version (snapshot or release) never existed in OpenWrt. It is likely a highly modified version from the vendor of your product.

You need to reach out to the vendor who supplied the product or the firmware for help.

it is based on 18.06.
Is there any wifi issues?
Which version do you recommend?
My modification have some custom patches as it uses non-open drivers.
I'm worry about the changes between 18.06 and latest(?) version..

I'm sorry for incorrect explanation... The version value that I thought is from uname -a
It is kernel version actually.. sorry.

"Based on" is the key phrase here... it is not from the OpenWrt project. A movie that is "based on" a book doesn't mean that the book's author wrote the screenplay, right?

Some vendor took OpenWrt and then heavily modified it for their product.

As for 18.06, this has been long since EOL and unsupported.

Not in official OpenWrt.

OpenWrt official, or reach out to the vendor.

What is the output of

ubus call system board

In that case, OpenWrt (official) won't contain such close-source drivers.

1 Like

…and with that, all common knowledge about OpenWrt go out of the window, you're not using anything open anymore, but a bastardized semi-proprietary kernel with closed source wireless drivers, in other words, we can't answer this previous question anymore:

There aren't any wireless issues in OpenWrt, who knows about the result of your firmware - at least we don't.

…and it usually doesn't stop at the kernel, not by far. Please talk to whoever provided you with your SDK, you've paid them, they need to do their customer service.

result of ubus call system board is...

root@OpenWrt:~# ubus call system board
{
"kernel": "4.14.111",
"hostname": "OpenWrt",
"system": "MediaTek MT7688 ver:1 eco:2",
"model": "WIZnet WizFi630S",
"board_name": "wizfi630s",
"release": {
"distribution": "OpenWrt",
"version": "SNAPSHOT",
"revision": "r9850+32-2101002b3d",
"target": "ramips/mt76x8",
"description": "OpenWrt SNAPSHOT r9850+32-2101002b3d"
}
}

and I'm the new person in charge of that product.
I should select the way, 'fix just wifi problem', or 'upgrade to newest openwrt version'

Your device is supported by the Official OpenWrt project...
https://firmware-selector.openwrt.org/?version=23.05.0&target=ramips%2Fmt76x8&id=wiznet_wizfi630s

What do you mean by this? Do you work for the company that makes the product?

That's up to you... you can either use official OpenWrt (latest version recommended), or you can work with the vendor (or your colleagues) to figure out what is wrong with your customized build.

1 Like

Thank you for your reply.
I'll try to use latest version.