Can't connect to v20.02 wifi

My d-link dir2660 A1 running stable release 20.02 have a number of wifi ssids. My Kubuntu PC, BCM43288 wifi chip, can't connect to all the ssids.

I also have an exact same setup on 19.07 on another AP, no problem connecting to all its ssids.

Both APs I connect, one AP at a time, to the same LAN port of my pfSense using the same VLAN ids. Main ssids (2.4 and 5ghz) and ssids associated with vlan ids, all can't be connected on version 20.02.

What could be the possible cause?

I'd look at the encryption (WPA2 vs WPA3) and the bandwidth settings of the radios.

2.4ghz@20mhz and 5ghz@40ghz.
I also tried both wpa/wpa2 and wpa2/wpa3. Can't connect as well.

Same pc if boot on Win10 can connect without problem for both 19.07 and 21.02.0 APs.

can you post your config files from 19.07 and 21.02 (specifically the /etc/config/wireless)

1 Like

Herebelow is the wireless config followed by network config on 19.07

root@bthoven_metal:/etc/config# cat wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/10180000.wmac'
	option htmode 'HT20'
	option channel 'auto'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option key 'xxxxxxxx'
	option ssid 'bthoven_metal'
	option encryption 'psk2+ccmp'

config wifi-iface 'wifinet1'
	option ssid 'bthoven_metal_bbc11'
	option encryption 'psk2+ccmp'
	option device 'radio0'
	option mode 'ap'
	option key 'xxxxxxx'
	option network 'bbc'

config wifi-iface 'wifinet2'
	option ssid 'bthoven_metal_iot_82'
	option encryption 'psk2+ccmp'
	option device 'radio0'
	option mode 'ap'
	option key 'xxxxxx'
	option network 'iot'
	
	
root@bthoven_metal:/etc/config# cat network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdaa:0d0a:8192::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '192.168.8.1'
	option ipaddr '192.168.8.254'
	list dns '8.8.8.8'

config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr '64:40:xx:xx:xx'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'

config device 'wan_eth0_2_dev'
	option name 'eth0.2'
	option macaddr '64:40:xx:xx:xx:xx'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '6t 1 2 3 4'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '6t 0'
	option vid '2'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option ports '6t 3t'
	option vid '11'

config interface 'bbc'
	option proto 'static'
	option ifname 'eth0.11'
	option type 'bridge'
	option ipaddr '192.168.11.254'
	option gateway '192.168.11.1'
	list dns '192.168.11.1'
	option netmask '255.255.255.0'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option ports '6t 3t'
	option vid '82'

config interface 'iot'
	option proto 'static'
	option ifname 'eth0.82'
	option type 'bridge'
	option ipaddr '192.168.82.254'
	option gateway '192.168.82.1'
	list dns '192.168.82.1'
	option netmask '255.255.255.0'

Herebelow is from another AP (d-link dir2660) on 21.02.00, the setting has wireless key set as wpa3; but as mentioned above, I did try wpa/wap2..same problem

root@bthoven_dlink:/etc/config# cat wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'HT20'
	option country 'US'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'bthoven_dlink'
	option key 'galileokepler'
	option encryption 'sae-mixed'
	option ieee80211w '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option cell_density '0'
	option htmode 'VHT80'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option key 'xxxxxxx'
	option ssid 'bthoven_dlink_5G'
	option encryption 'sae-mixed'
	option ieee80211w '1'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option ssid 'bthoven_dlink_bbc11'
	option key 'xxxxxx'
	option network 'bbc'
	option ieee80211w '1'
	option encryption 'sae-mixed'

config wifi-iface 'wifinet3'
	option device 'radio0'
	option mode 'ap'
	option ssid 'bthoven_dlink_iot82'
	option network 'iot'
	option key 'xxxxx'
	option encryption 'sae-mixed'
	option ieee80211w '1'

config wifi-iface 'wifinet4'
	option device 'radio0'
	option mode 'ap'
	option encryption 'sae-mixed'
	option key 'xxxxx'
	option ieee80211w '1'
	option network 'guest'
	option ssid 'bthoven_dlink_guest'
	

root@bthoven_dlink:/etc/config# cat wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'HT20'
	option country 'US'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'bthoven_dlink'
	option key 'galileokepler'
	option encryption 'sae-mixed'
	option ieee80211w '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option cell_density '0'
	option htmode 'VHT80'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option key 'galileokepler'
	option ssid 'bthoven_dlink_5G'
	option encryption 'sae-mixed'
	option ieee80211w '1'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option ssid 'bthoven_dlink_bbc11'
	option key 'galileokeplerbbc'
	option network 'bbc'
	option ieee80211w '1'
	option encryption 'sae-mixed'

config wifi-iface 'wifinet3'
	option device 'radio0'
	option mode 'ap'
	option ssid 'bthoven_dlink_iot82'
	option network 'iot'
	option key 'galileokepleriot'
	option encryption 'sae-mixed'
	option ieee80211w '1'

config wifi-iface 'wifinet4'
	option device 'radio0'
	option mode 'ap'
	option encryption 'sae-mixed'
	option key 'guestcccp'
	option ieee80211w '1'
	option network 'guest'
	option ssid 'bthoven_dlink_guest'

root@bthoven_dlink:/etc/config# cat network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fd57:4e11:dc9f::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan1:u*'
	list ports 'lan2:u'
	list ports 'lan3:u'
	list ports 'lan4:u'

config interface 'lan'
	option device 'br-lan.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.8.254'
	option defaultroute '0'
	option gateway '192.168.8.1'
	list dns '8.8.8.8'
	list dns '10.100.0.1'

config bridge-vlan
	option device 'br-lan'
	option vlan '11'
	list ports 'lan1:t'

config interface 'bbc'
	option proto 'static'
	option netmask '255.255.255.0'
	option delegate '0'
	option device 'br-lan.11'
	option ipaddr '192.168.11.254'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config bridge-vlan
	option device 'br-lan'
	option vlan '82'
	list ports 'lan1:t'

config interface 'iot'
	option proto 'static'
	option device 'br-lan.82'
	option ipaddr '192.168.82.254'
	option netmask '255.255.255.0'
	option gateway '192.168.82.1'

config interface 'bbc_wg'
	option proto 'wireguard'
	option private_key 'xxxxxEErE9Ch90Q='
	option listen_port '51820'
	list addresses '10.100.1.97/32'
	option peerdns '0'
	option auto '0'

config wireguard_bbc_wg
	option description 'bbc vpnunlimited'
	option public_key 'xxxx/bTgs='
	option preshared_key 'xxxxxl3ooB79hy4='
	list allowed_ips '0.0.0.0/0'
	option route_allowed_ips '1'
	option endpoint_host 'xx.xxx.180.82'
	option endpoint_port '51820'
	option persistent_keepalive '25'

config interface 'guest'
	option proto 'static'
	option device 'wlan0-3'
	option ipaddr '192.168.99.254'
	option netmask '255.255.255.0'
	list dns '8.8.8.8'
	option defaultroute '0'

When you tested wpa/wpa2, did you also remove the Management Frame Protection ieee802.11w setting?
Some wifi drivers and clients choke with it.

I did disable it on Luci gui, not help