Cant connect to router after install

Problem:
I can't find my router at 192.168.1.1. Either with a browser, ping or ssh. They all time out.

Setup:
I'm setting up OpenWRT with the hardware in How can I describe my problem better? (Meta)

In particular, I have a DFR0767 CM4IoT Router Board Mini (V1.0) on a CM4002000 with 2GB RAM and a class 10 16GB microSSD.

Stuff I've tried:
Images I've tried:
The latest image from DFRobot https://img.dfrobot.com.cn/wiki/5d303ff74db88f1df9d80a04/54317b71156f96d6b410aca5c956ed33.zip
The latest stable image form OpenWRT https://downloads.openwrt.org/releases/22.03.5/targets/bcm27xx/bcm2711/

Configurations I've tried:
modem->DFrouter->computer
modem->Orbi->switch->DFrouter->computer

I've tried both of those with swaping ETH0 and ETH1, incase they were mislabled

Flash methods I've tried:
plug the SD into my computer with both rufus and etcher
RPiboot on an Ubuntu over VMWare

I just ordered a USB to Serial cable but I'm wondering if there are other things I might try until then.

Try an alternate os - such as raspian and see if that boots and gets an ip address via dhcp

You’ll then know whether the cm4 and board are working at all

1 Like

I was able to install the standard 64 bit Raspberry Pi OS through the Raspberry Pi Imager.

Once I plugged the WAN port into my switch like:
Modem->Orbi->switch->DFRoouter

I was able to find the IP and then connect via SSH.

It seems like the obvious things to try are:

  1. See if I can get the ELF and DAT files added to the DFRobot image as discussed in https://www.dfrobot.com/forum/topic/312284
  2. Try to install the DFRobot images via the RPi Imager instead of Rufus or Etcher

1 seems complicated and I haven't found clear instructions for it. It seems odd that the Imaging software would be the problem so I'm dubious that 2 will work.

Short of waiting for that cable, are there other obvious things to try/test?

I don't know what DFRobot is, you need to ask for help over there.

As for images from downloads.openwrt.org, realize that they are gzip compressed and need to be uncompressed before or during the process of writing to the card. gzip is not the same as .zip file though I think that full-featured Windows applications like 7zip can process them. Use either the squashfs-factory or the ext4-factory image for the first write to a card.

You really need a console to see what’s failing, but it could be as simple as the kernel modules for the dfrobot board not being included in the standard image.

Try building a custom image with the image builder and adding modules for their Ethernet controllers

1 Like

Much to my surprise, flashing the DFRobot image with the Pi Imaging tool seems to have done the trick.

Lots of people seem to use both Rufus and Etcher so I'm shocked that just switching to an other imaging tool made any difference.

I was able to inline it with my modem:
modem->dfrobot->switch->computer

and connect to 192.168.1.1

I would suggest to switch to the official OpenWrt image https://firmware-selector.openwrt.org/?version=23.05.0&target=bcm27xx%2Fbcm2711&id=rpi-4
(the DFRobot images are outdated and not maintained anymore)

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.