Can't connect to internet since LEDE 17.01.6

Dear All,
i am stuck with LEDE 17.01.6 on my Aztech HW550-3G. All further releases have failed to connect to internet. I still haven't figured out a way to find out why, there is enough memory, the modem gets an IP from the router, but it won't ping anything. So i have to use the latest LEDE release.
Has anyone experienced a similar problem ?
Any hints or tools to diagnose this problem ?

When you tried upgrading, did you keep settings or directly restore a backup configuration?

It is generally best practice to not keep settings when upgrading across major versions. That also includes not restoring a backup from a previous major revision.

After flashing, you'll need to reconfigure the router -- a backup can serve as a great reference in this situation, and unless your config is complex, it should be pretty quick to configure at least the basics.

1 Like

Hi psherman,
no actually it works without any settings, just connect wan (router) to lan (modem) and it works. Not anymore since the project name changed from LEDE to openWRT.

There are settings, but it sounds like you're using the default settings -- can you confirm that?

When you have upgraded, there should have been an option to keep settings. That should be disabled so that it does not keep the existing settings (even though you may not have configured anything yourself). Did you have that option enabled or not?

Finally, you must be more specific -- what do you mean that it isn't working when you upgrade to a newer release? What specifically happens? Does your computer get an IP address? Can you ping the router? Can you ping the internet via an IP address ( or a domain name (

1 Like

Hi @psherman,
yes i reset the setting with each flashing (unchecked the option to save settings)
the computer gets an ip address, the modem gets an ip address from the router, but when pinging it doesn't. I does however ping

~ ssh root@
root@'s password:

BusyBox v1.30.1 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 OpenWrt 19.07.2, r10947-65030d81f3
root@OpenWrt:~# ping
PING ( 56 data bytes
64 bytes from seq=0 ttl=53 time=72.986 ms
64 bytes from seq=1 ttl=53 time=61.345 ms
64 bytes from seq=2 ttl=53 time=82.253 ms
64 bytes from seq=3 ttl=53 time=76.967 ms
--- ping statistics ---
4 packets transmitted, 4 packets received, 0% packet loss
round-trip min/avg/max = 61.345/73.387/82.253 ms
root@OpenWrt:~# ping
ping: bad address ''
root@OpenWrt:~# ping
ping: bad address ''

here are some screenshots please talk a look at them they show both lede-17.01 and openwrt 19.07

LAN and WAN cannot both use since the router thinks it's the same network and therefore won't route LAN traffic to WAN!

Try renumbering LAN to e.g.

1 Like

@lleachii : But the LEDE setup is the same as the openWRT and it works !
which means that it's not the preblem... right?


So...I'd say wrong.

Let us know when you desire to fix your subnetting and test from there.

1 Like

First, @lleachii is right about the subnetting issue. It may not be your only problem, but it is a problem and you will never have a functioning network if you don't fix it.

Moving on -- the OpenWrt and LEDE default network configurations have generally been the same, including the default address at (much of the stuff under the hood has changed since LEDE, so the actual configs may not be the same in terms of details). However, chances are that you were not using a completely default LEDE configuration, especially the LAN address/network (even if you don't remember setting it). Otherwise, LEDE wouldn't have worked, either. That is, of course, unless other things changed such as the introduction of another device upstream of your OpenWrt router.

Which leads me to this: what is connected to the WAN port of your OpenWrt router (i.e. upstream)? It seems that there is another router connected between your ISP and your OpenWrt device (is it a combination router/modem, or a standalone router)? This is an incredibly important piece of information and is the reason that you have the issue with the LAN and WAN using the same network scope. The upstream router should ideally not be there at all (or if it is a combo modem + router unit, should be set to bridge mode if at all possible). However, if it must be there and cannot be in a bridge mode, the address/network on one of the devices must be changed.

It also appears that you have a DNS related issue. But let's solve the subnet issue first - it may resolve both problems at the same time.

Finally, the advice you get here is only as good as the information you provide in terms of details to help resolve your issue (we only learned about your subnet issue by accident, you have been very vague in your descriptions about your issues and network configuration).

Please be considerate of this all volunteer group of contributors on this forum, many of whom who have some considerable expertise and experience with OpenWr and networks in general. I trust @lleachii's advice and expertise, and I suggest you should, too.


Hello guys the delay was caused by a problem i encountered while trying to change the dhcp pool in the upstream router (thinking it would help me solve the subnet issue) but it stopped working then i had to reset it wait for the isp to give me the telnet password so i can go back online. Now that it's fixed (and i have the telnet password) i can reply to you :smiley:
@lleachii : of course i am willing to fix the subnetting issue. Thank you for pointing it out, i only tried to say that the same settings are used in the default LEDE setup and despite that it can connect to internet.

@psherman : i will do my best to be as specific as possible, mea culpa :slight_smile:

i made the screenshots using freshly installed bins both times erasing the settings, the default lede installation connects successfully, the openwrt doesn't ( as shown in the screenshots ). The weird thing is that they have the same network addressess both for lan and wan, and LEDE worked out of the box, that's why i presumed the subnet configuration wasn't the culprit.

sorry i should have mentioned that it was a router/modem (Technicolor tg789vn V3)

now, when i try to change the lan ipv4 address from the default ( to it says waiting for configuration to get applied and then reverts back to old settings. can you please explain how to change the subnet of the lan interface ?

It's an emergency revert feature....

  • Or even better, you can simply click "Apply Unchecked" when it appears :wink:
  • If this doesn't work - edit in /etc/config/network and reboot
1 Like

Hurray i applied it, reactivated the interface in networkmanager and i got connected under 192.168.2.x address !
I can access the router now and internet is working.
Thank you @psherman and @lleachii for your assistance you have been really great :smiley:


Glad it is working. I really cannot explain how and why it was working with LEDE if the LAN address was the same as the WAN address -- this is a condition that should cause all routers to fail to route, nothing unique with OpenWrt in this sense. But now that it is working, you should hopefully be able to enjoy the new version!


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.