Can't connect to Access Point

I try to make a wifi bridge with my old router DLink Dir-615 and the Ubiquiti AP AC Pro. But when I configured the wireless connection at the Dir-615 with Lede 17.01 the message appears: Wireless is disabled or not associated.
Wireless is activated and it works with other Wifi networks. Both support the standards: 802.11 b/g/n.

Thank you for your help!

LEDE 17.01 is no longer maintained or actively supported, you should upgrade to OpenWrt 19.07.

However, the D-Link DIR-615 in any variant cannot run OpenWrt 19.07 out of the box since it does not have enough flash and RAM. To save firmware space, a custom build of OpenWrt would be required, either from source or using the Image Builder. Depending on how much you like tinkering and your available time, it might be better to replace the device.

Is the Ubiquiti AP AC Pro also running OpenWrt? In this case, the best solution for a wireless bridge would be WDS.
Which wireless bridge configuration did you try?

1 Like

The Ubiquiti AP AC Pro is running in the stock firmware. I tried to create the wifi bridge with the relayd package.

I suggest to try a simple wifi client configuration first, before adding relayd.

If there still are problems, please post your configuration files (network, wireless) with redacted secrets.

Doesn't work for me, same error.

Network config:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdee:ef50:b927::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.2.1'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr '62:25:fa:f2:b2:55'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'

config device 'wan_dev'
	option name 'eth0.2'
	option macaddr '62:25:fa:f2:b2:56'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'rt305x'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'rt305x'
	option vlan '1'
	option ports '0 1 2 3 5 6t'

config switch_vlan
	option device 'rt305x'
	option vlan '2'
	option ports '4 6t'

config interface 'wwan'
	option proto 'dhcp'

Wireless config:

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/10180000.wmac'
	option htmode 'HT20'
	option disabled '0'
	option channel '13'
	option country '00'

config wifi-iface
	option network 'wwan'
	option ssid 'AP Lange'
	option encryption 'psk2'
	option device 'radio0'
	option mode 'sta'
	option bssid 'E0:63:DA:3A:CC:62'
	option key '<password>'

Set the proper country code for your location.

Make sure this matches the AP's BSSID, or remove the option temporarily as an experiment.

While there is nothing wrong with this option:

it has no effect in client mode, where the channel is chosen by the AP. You can ignore it for now.
Instead, please check which channel is configured on the AP. Try to set it to a different one.

2 Likes

While trying to edit the channel on the AP, I couldn't log into it so I reseted the AP and set Channel to 11. After connecting to the AP it worked for like 2 seconds and then the message Wireless is disabled or not associated appeared again. -_-

Did you fix the Country again?

???

As noted, not valid in client mode; and this channel is not available in most nations anyway.

I changed it to channel 11 already. I tried all suggestions by @mpa .

What hardware version?

:warning: Broadcom chips cannot do "wifi bridging" on OpenWrt.

D-Link Dir-615 D1, runs with a MediaTek/Ralink chip.