Can't connect my devices to 5GHz wifi of my router but 2.4GHz works fine

I have a Netgear R3800 which I installed 23.05.5 on. I haven't changed any settings except that I installed travelmate. I disconnected it from the 5GHz upstream AP to see if that was keeping me from connecting to the 5Ghz wifi it was making but it didn't help.

This is the configuration file I think. I got it from the system log if that might give any clues.

Wed Jan 1 21:41:05 2025 daemon.notice hostapd: Configuration file: data: driver=nl80211 logger_syslog=127 logger_syslog_level=2 logger_stdout=127 logger_stdout_level=2 hw_mode=a beacon_int=100 chanlist=36 noscan=1 #num_global_macaddr=1 ieee80211n=1 ht_coex=0 ht_capab=[SHORT-GI-40][TX-STBC][RX-STBC1][DSSS_CCK-40] channel=36 interface=phy1-ap0 bssid=4c:60:de:e6:a7:d6 ctrl_interface=/var/run/hostapd bss_load_update_period=60 chan_util_avg_period=600 disassoc_low_ack=1 skip_inactivity_poll=0 preamble=1 wmm_enabled=1 ignore_broadcast_ssid=0 uapsd_advertisement_enabled=1 utf8_ssid=1 multi_ap=0 auth_algs=1 wpa=0 ssid=OpenWrt5GHz qos_map_set=0,0,2,16,1,1,255,255,18,22,24,38,40,40,44,46,48,56 #default_macaddr nas_identifier=4c60dee6a7d6 (phy phy1) --> new PHY

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
2 Likes

Here they are in order

{
        "kernel": "5.15.167",
        "hostname": "OpenWrt",
        "system": "Atheros AR7161 rev 2",
        "model": "Netgear WNDR3800",
        "board_name": "netgear,wndr3800",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.5",
                "revision": "r24106-10cc5fcd00",
                "target": "ath79/generic",
                "description": "OpenWrt 23.05.5 r24106-10cc5fcd00"
        }
}
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd0:4084:9302::/48'

config interface 'wan'
        option device 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config device
        option name 'eth0'
        option macaddr 'XXXXX'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option blinkrate '2'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5'

config switch_port
        option device 'switch0'
        option port '1'
        option led '6'

config switch_port
        option device 'switch0'
        option port '2'
        option led '9'

config switch_port
        option device 'switch0'
        option port '5'
        option led '2'

config interface 'trm_wwan'
        option proto 'dhcp'
        option metric '100'

config interface 'trm_wwan6'
        option device '@trm_wwan'
        option proto 'dhcpv6'

config interface 'wwan'
        option proto 'dhcp'
config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:11.0'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'Dayroom wifi'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:12.0'
        option channel '36'
        option band '5g'
        option cell_density '0'

config wifi-iface 'wifinet3'
        option device 'radio1'
        option mode 'ap'
        option ssid 'OpenWrt5GHz'
        option encryption 'none'
        option disabled '1'

config wifi-iface 'trm_uplink3'
        option device 'radio1'
        option mode 'sta'
        option network 'trm_wwan'
        option ssid 'CoxWiFi'
        option encryption 'none'
        option disabled '0'
config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'
        list rebind_domain 'uwp-wifi-access-portal.cox.com'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'
config defaults
        option syn_flood '1'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'wan6'
        list network 'trm_wwan'
        list network 'trm_wwan6'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

That is not nothing: Travelmate is persnickety.

Is it your intention to use the router as a travel router?

You don’t have an ssid defined and active on the 5g radio. So it makes sense that you cannot connect.

1 Like

Your AP is disabled.

Your 5G radio is in station mode (aka client mode).

Your 2.4g radio is set up to be the AP.

So, your 5G is probably working but it is configured to be a client (your original backhaul?).

Then you added Travelmate.
I don't know the cat call to look at its config but I'll save you time:
You added the package, you cannot recover the memory space without starting over (deleting it just hides it) and unweaving Travelmate may be a steeper learning curve than starting over.

:spiral_notepad:
!!!!!***

That is Travelmate making its own settings.

1 Like

So I can't have the radio act as both client and AP? My main reason for doing this is to use it as a travel router for my PS3 which can't connect to the 5GHz APs and it works fine for that. There's no ports anywhere to do it wired.

I wanted the option of having other devices connect to the router on the same 5GHz network. I can see the 5GHz network name but can't connect to it. I don't know why it doesn't show an SSID in the log.

You can but you need to learn travelmate.

Here is the support thread.

If 'the' is a pronoun for 'radio1', then no:
One radio is AP, one is STA.
You have one 2.4g radio and one 5g.

1 Like

I said radio and not router to try to specify I wanted both networks to be the same type.

I was trying to not use 2.4 GHz at all. Have the router make a 5GHz network for other devices and connect to a 5GHz network to get to the internet.

I thought that was possible because Travelmate advised 2.4 be used for one and 5 be used for the other but it didn't say it was mandatory. The backhaul gets 40Mbps down and it goes down to 30 when connected using 2.4 so I thought there was a chance it could work better with only 5G.

Just reminded me of an issue I was experiencing with an old Iphone not connecting to 5G. I changed the channel from Auto (it was using 138) to 161 and now the Iphone can see 5G network. But your case might be different, in my case the other 5G devices were seeing the network even on channel 138.

Some (old) chipsets can do both at the same time but I do not see that as a feature.

You still need to decide about learning travelmate or wiping it and starting clean.

It's all over your configs:

What's wrong with my config? It's been working fine.

1 Like

Going back to the question about travelmate in the first place... is this device being used as a travel router or in any situation where you must use a wifi uplink to an upstream network? If so, please elaborate on the specifics of your network topology. If not, you don't need travelmate and you may be best served by starting fresh.

A clear description of this device's use-case and your network topology willl be really helpful.

Yes. There are no ethernet ports in the room I'm setting this up in. There is a coax port but I don't want to pay for a second ISP subscription.

Everyone's gateway from Cox makes a second network with a captive portal you can use if you subscribe to them and that's what I'm using for an uplink.

The 2.4GHz wifi from the gateway I rent from Cox doesn't reach from my room to the room I have my PS3 in and I want the gateway in my room for my PC.

I know there is Moca which these gateways support. Could I connect a modem to the coax port which would connect back to my room's gateway for Internet access?

So is your intent to repeat your existing wifi network from Cox? Or do you want to have a separate (routed) network downstream of your OpenWrt router?

If you want to repeat the existing network, you need relayd:
https://openwrt.org/docs/guide-user/network/wifi/relay_configuration

Yes but it is not cheap.

A separate downstream network which is already working.

I just thought it could be a little faster if I used 5G for uplink and downlink instead of what I currently had. It does broadcast an SSID for the 5G downlink with Travelmate running but it just won't let other devices connect to it which is why I thought it was a configuration problem.

So you don't necessarily need Travelmate.

The purpose of the Travelmate package is to handle the situation where the upstream wifi network (to which the OpenWrt device will connect) may not be available. If the STA mode connection cannot be established, AP cannot start because the it is the STA connection that determines the channel for the AP (so STA must be up first). Travelmate handles this situation by failing gracefully (by means of a timeout and a list of SSIDs to try)/

This issue shows up most often in a travel context... maybe you are now at a different hotel with a different wifi SSID... the previously used SSID is obviously not at the new location, and therefore the STA mode fails, causing the AP mode to fail to initialize, too.

If you can be reasonably certain that the upstream network will not be changing, you don't need travelmate. So you may want to start over so you don't have the added complication of a package you don't need.

Follow this guide to setup your OpenWrt router as a wfii client (wwan), and then setup a downstream AP mode SSID on both the 5G and 2.4G bands.

https://openwrt.org/docs/guide-user/network/wifi/connect_client_wifi

1 Like