Can't connect in failsafe to Storylink SAP G3200u3


I recently installed LEDE 17.01.4 on a STORYLiNK SAP-G3200U3 (MediaTek MT7621, lede-17.01.4-ramips-mt7621-sap-g3200u3-squashfs-sysupgrade.bin). Unfortunately, due to a bad choice of firewall settings, I've locked myself out of the router and cannot connect to it any more. I've been trying to connect in safe mode, but with no success so far.

I've followed the failsafe instructions and I think I get the router to go into failsafe. The sequence seems according to the instructions. I pressed the button when the LED is blinking, and soon after it starts blinking much faster (and stays like that). However, I can never see, ping, or connect to I tried connecting through the WAN port, through all the other LAN ports but the result is identical.

Also, using wireshark I can't seem to see any UDP traffic on port 4919. I've also tried using the reset button to enable the TFTP server recovery (like I did to flash LEDE from the stock firmware), but it also doesn't work (blinking LED seems very much the same as in failsafe mode). Is it possible that installing LEDE also rewrote the bootloader?

Any clue on how I can connect back to it?