Can't configure network settings

Hey guys, I got an Mikrotik Routerboard 750gr3. Ive installed OpenWrt Version openwrt-23.05.0-rc3. Now I want some changes in the vlan and interface settings. For this I used the following settings in /etc/config/network. Here are the Settings:

config globals 'globals'
option ula_prefix 'fdf7:aefc:1ed9::/48'

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '1 6t'
option vid '2'

config switch_vlan
option device 'switch0'
option vlan '3'
option ports '2 6t'
option vid '3'

config switch_vlan
option device 'switch0'
option vlan '4'
option ports '3 6t'
option vid '4'

config switch_vlan
option device 'switch0'
option vlan '5'
option ports '4 6t'
option vid '5'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 6t'
option vid '1'

config interface 'mgmt'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
list dns '8.8.8.8'
option gateway '10.13.1.201'
option ipaddr '10.13.1.200'
option ifname 'eth0.1'

config interface 'ovs2'
option ifname 'eth0.2'
option proto 'none'
option force_link '1'

config interface 'ovs3'
option ifname 'eth0.3'
option proto 'none'
option force_link '1'

config interface 'ovs4'
option ifname 'eth0.4'
option proto 'none'
option force_link '1'

config interface 'ovs5'
option ifname 'eth0.5'
option proto 'none'
option force_link '1'

After I deleted the old content of the network file and replaced it with this, I rebooted the board. When I plug in my port 1 (configured as mgmt) I can't connect to 10.13.1.200. I assigned my pc the ip adress 10.13.1.201. The boards usr is always on. What's the problem with this configuration?
Additional: I didn't want to connect to the internet. Only to my laptop (10.10.1.201) via ssh

Maybe switched to DSA instead of swconfig?

Reset to defaults and after that update to 23.0.5.3 which is the latest stable build then compare the existing network after the reset with the one you want.

Hey, I updated to 23.05.03 and the network settings are the same as before. What is DSA? I searched the packages which installed but can't find swconfig or DSA.

You, also, assigned your gateway to 10.13.1.201

so I need a other ip adress for my devices? like 10.13.1.202?

Your gateway needs to be your modem address. AKA your gateway/modem device. This is usually assigned by the modem using DHCP.

Your router and pc address can stay as you have them as long as the modem/gateway is on a different subnet.

sry, but I didn't understand it. want to use my modem as a laptop. The MikroTik will not be connected to the internet, only to my laptop. I just want to establish an SSH connection between my laptop (10.13.1.201) and the MikroTik.

What is that then?
They are not even close to the same subnet.

Something is getting lost in translation and I cannot figure out your goals or your network.

Someone else will need to sort this out.

Try drawing a picture, maybe that will help.

my bad. A spelling mistake. So I assigned my laptop the ip address 10.13.1.201 NOT 10.10.1.201. Ive just want to configure my router board as an sdn switch. Ive got the fitting configurations (posted above in my question). After applying them, scant connect via ssh to my routerboard. Ive used the command: ssh root@10.13.1.200. Hope that's clearing the mistake.

use
ssh 10.13.1.200

Better than that: use Putty.

that didn't work

Download putty and use it.

If that does not work I'm lost.

I cant even ping the device on the ip address 10.13.1.200

I'm terrible at VLANs.

I have no idea how to fix your config and since you cannot ssh into it we cannot even make config calls.

I'm sorry but you are stuck. You cant even make changes because your device is unreachable.
I'd tell you to start over but even then you'd just be waiting for someone to look at your VLAN config before you apply it.

You can try setting your laptop to DHCP for network settings and hope the DHCP server is working.

yeah that's hard to figure it out... I hope some hero is online :wink: but thanks for trying to help me !

1 Like

Someone will come along that knows more than me. Don't worry about that.

1 Like

I suspect that this broke your unit (soft-brick, recoverable).

I think that @egc is correct -- your system probably transitioned to DSA.

DSA is Distributed Switch Architecture and represents an entirely different approach to how the switch is configured vs the previous approach of swconifg (which is what your example syntax was)... the two are not compatible, but you won't find packages for DSA or swconfig -- it's deeper in the system than that. The best way to know (aside from doing a bit of research) is to simply look at the default config.

Since you're locked out currently, you need to use failsafe mode to regain access:
https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset

Note that you need to set a static IP on your computer and directly connect via ethernet.
Once you're in via failsafe mode, you'll reset with this command:

firstboot -y && reboot

The device will reset and reboot. Once that is done, you will need to connect via ssh and grab your network config file. Be aware that you may get a warning on your computer about the ssh key having changed... that's normal, just follow the directions it gives you to clear the old key.

Post your default config file here so that we know what we're dealing with.

Then, we also need to have a better idea of exactly what your desired configuration will be. It appears that you may want this to be a managed switch, but we it would be helpful for you to provide a description:

  • on a port-by-port basis what VLANs are expected on each
    • If multiple VLANs are present on one of the ports (i.e. a trunk) are they all tagged or is any network untagged (if so, which one)
  • Will this device be routing or purely a switch (where there is presumed to be a router with all these networks already defined upstream)
  • What VLAN and address is used for management of this device

A diagram can also be really useful.

First of all thanks for helping and giving me some Informations. For resetting, I rested via the reset button. Holding in for 10 seconds. Now here are the default settings:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd3c:bb3e:760f::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'lan5'

config device
        option name 'lan2'
        option macaddr '48:a9:8a:ec:b1:72'

config device
        option name 'lan3'
        option macaddr '48:a9:8a:ec:b1:72'

config device
        option name 'lan4'
        option macaddr '48:a9:8a:ec:b1:72'

config device
        option name 'lan5'
        option macaddr '48:a9:8a:ec:b1:72'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'wan'
        option macaddr '48:a9:8a:ec:b1:71'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

For better understanding what I want I got some pictures of a previous configuration. I want to configure the exact settings.


The problem here is the my Lucy has no switch settings. To get a switch I set up a new bridge and added all the ports, now I can configure them as vports:


I don't understand why I got lan 2,3,4,5 and on the picture they got only 1,2,3,4. Its the same device but using openWrt 19.07

Your router has switched to DSA indeed.

There is no switch config tab for DSA, rumour has it that it should be easy to do via the config files :wink:

See: https://openwrt.org/docs/guide-user/network/dsa/start

Not a DSA expert yet so cannot help you much further :frowning:

@thesearchingfor - I see you have opened a new thread....
Is that for the same device (it appears so) and the same goal)?

If so, we should close one of the threads and continue on the other because otherwise things get very confusing, very fast.

Beyond that, haven't read the details yet of what you are trying to achieve, but it is clear that your device is DSA and I should be able to help you reach your goals. Let me know which thread you would like to close we'll continue in the appropriate one. (my recommendation would be to close this one and resume the conversation in the other since the topic titles then track fairly well against the goals).

1 Like