Can't change root password

Hi.
i have just compiled openwrt from main branch for BT-HH5 and disabled a lot of default options when running make menuconfig now when i ssh into the router and try to change root password with passwd it throws an error "passwd: bad salt" and does not assign or change root password
can you tell me which symbols i have disabled which is causing this issue.

You realize that this a tad insufficient information to provide any assistance?

The default OpenWrt images are supposed to work, there isn't really anything 'optional' in there (and you have quite a lot of flash and RAM to play with, so I don't get why you'd even want to remove 'default options' from it, rather than adding stuff).

So this is a case of, "if it hurts, don't do it".

…or rather, it's an opportunity for you to bisect your changes, find the problematic one(s) and to understand what they're actually doing.

2 Likes

We can't possibly answer this without a list of what default options you disabled. If you don't know or can't provide this information, you need to start over from scratch. Make a default build first and verify that it works before messing around with the options.

If you do make any changes to the default options, take detailed notes about what you changed. Be prepared to explain to yourself and others on this forum why you made those changes. OpenWrt isn't an "everything but the kitchen sink" Linux distribution, so if it's included by default there's usually a reason why it's there.

2 Likes

Bad salt…ok.
My guess that you removed something called rng or something similar.
Don’t do that!

1 Like

install the luci-app-acl package and you can change root

this was the symbol i disabled that caused it
` .config - OpenWrt Configuration

Advanced configuration options (for developers) > Toolchain Options ────────
...
β”‚ β”‚ *** C Library *** β”‚ β”‚
β”‚ β”‚ C Library implementation (Use musl) ---> β”‚ β”‚
β”‚ β”‚ Include crypt() support for SHA256, SHA512 and Blowfish cipβ”‚ β”‚
`

Do you mean this one?
Well, like I said. Don’t turn off the rng…

To make random numbers you need seeding of random data and then you salt the seeded data.

yep compiled again with that symbol enabled and it works now. i was trying to compile a minimal build and turned off some symbols earlier.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.